LT1 Based Engine Tech 1993-1997 LT1/LT4 Engine Related

help it stopped running

Old 12-13-2018, 11:13 AM
  #1  
New Member
Thread Starter
 
Join Date: Dec 2018
Posts: 1
help it stopped running

ive got 93 z28 and yesterday . car started missing then it was shaking lil ,car stopped running ,and it want crank up again , ive put new plugs and wires on it changed oil , fixed mount on transmission ,even had put new frontend under it , ive put like 2300 dollars in it in 3 weeks .. yesterdasy it started missing and stop running ,whats wrong with it ,i need help
Kristie Davis is offline  
Old 12-13-2018, 02:44 PM
  #2  
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 66,997
Re: help it stopped running

You aren’t going to get a lot of tech help in “Site Help and Suggestions”. It’s for issues with the way the site software performs.

I'll move this to “LT1 Based Engine Tech” for you.

Have you scanned it for codes (very easy to do on a 93, no scanner required)? Have you checked the fuel pressure? Have you checked for spark at the plugs and at the coil wire? Did you replace the plugs and wires BEFORE or AFTER it stopped running?



Injuneer is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RyanD
LT1 Based Engine Tech
6
09-02-2007 01:56 PM
RED82TA5.7L
3rd Gen / L98 Engine Tech
0
04-10-2006 01:59 PM
Hood_Lum
LT1 Based Engine Tech
16
01-02-2005 12:28 AM
Hood_Lum
General 1967-2002 F-Body Tech
2
12-16-2004 11:56 PM
97TransAm
LT1 Based Engine Tech
4
06-23-2003 10:09 PM


Thread Tools
Search this Thread
Quick Reply: help it stopped running


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.