LT1 Based Engine Tech 1993-1997 LT1/LT4 Engine Related

oxygen sensor question

Old 08-13-2008, 08:11 PM
  #1  
Registered User
Thread Starter
 
Join Date: Jan 2001
Location: Florence Mississippi
Posts: 871
oxygen sensor question

hey all. i saw a post on here before but cant seem to find it to save my life now about someone using rear oxygen sensors from a 96-97 car on the earlier ones when using long tubes since they are farther down stream. can someone confirm this for me cause ive been having problems and i need to buy some new ones anyway. thanks in advance
1badasZ is offline  
Old 08-13-2008, 11:32 PM
  #2  
Registered User
 
shoebox's Avatar
 
Join Date: Dec 1969
Location: Little Rock, AR
Posts: 27,596
The rear O2s don't have the same connectors as the front O2s, so they won't even plug in.
shoebox is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mikey4play
LT1 Based Engine Tech
22
03-15-2015 11:45 AM
Queens94z28
Parts For Sale
3
12-20-2014 09:11 PM
AlaskaZ28
LT1 Based Engine Tech
4
12-16-2014 07:24 PM
AlaskaZ28
New Member Introduction
2
12-10-2014 02:39 PM
AlaskaZ28
LT1 Based Engine Tech
1
12-10-2014 02:37 PM


Thread Tools
Search this Thread
Quick Reply: oxygen sensor question


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.