96 Z28 headlights not working. need help. - CamaroZ28.Com Message Board


General 1967-2002 F-Body Tech For general F-Body discussion that does not fit in any other forum.
For F-Body Technical/Information Discussion ONLY


Reply
 
Thread Tools Search this Thread
Old 11-13-2009, 07:33 PM   #1
Registered User
Thread Starter
 
Join Date: Nov 2009
Posts: 3
96 Z28 headlights not working. need help.

i have a 96 Z28, when you turn the headlight switch to on, the bell will ding rapidly to let you know the headlights are on, so i know the switch is working. but the headlights do not come on, they dont work high or low beams. when i check the fuse box under the hood, the location for the "L hdlp" and the "r hdlp" according to the inside of the lid as location 3 and 4 are missing fuses. after closer inspection i discovered there is not even a fuse holder in the hole. does anyone know why this vehicle is this weay. it does not seem to have been tampered with at all. it also had fog lights but there is only the brackets remaining. im not sure that they would have anything to do with the headlights but you never know.
i just aquired this car so i do not know the history.
TimFromArkansas is offline   Reply With Quote
Old 11-20-2009, 12:54 AM   #2
Registered User
 
Join Date: Nov 2009
Posts: 10
You may have a short in the wiring somewhere. I have a 96 z28 as well and I'm having trouble with my lights. Whenever I turn my headlight switch on my headlights work but no other lights work. My tail lights, corner lights, fog lights, and my dashboard light are all out.
mattoney01 is offline   Reply With Quote
Old 11-20-2009, 09:21 PM   #3
Registered User
Thread Starter
 
Join Date: Nov 2009
Posts: 3
yours sounds like a relay, but wow the exact opposite problem. have you located the fuses for your headlights? or even a relay? if so id like to know where they are located so that i can compare to my car. im starting to think someone may have wired around the fusebox on my car or something.
TimFromArkansas is offline   Reply With Quote
Old 11-20-2009, 11:06 PM   #4
Registered User
 
Join Date: Nov 2009
Posts: 10
yea, I looked at the fuse box and mine is missing the L hdlp and R hdlp as well. I checked the fuses and they're fine but I didn't check the relay. I done some research on it and a lot of people say that it's my switch. Mine doesn't make a sound whenever i turn the switch on though unlike yours. Sorry I cant be much help
mattoney01 is offline   Reply With Quote
Old 11-21-2009, 07:31 AM   #5
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 45,792
The headlamps are protected by a fusible link. Then there's the relay, that appears to be part of the headlight switch assembly. Shoebox has the schematic for the lights on his website. Start in the upper left corner for the fusible link. This is for a 95, but your 96 will be similar:

http://shbox.com/1/headlight_chevy_1995.jpg

The fusible links are at the red + box near the battery.

http://shbox.com/1/fusible.jpg
Injuneer is offline   Reply With Quote
Old 11-21-2009, 09:26 AM   #6
Registered User
 
Join Date: Apr 2009
Location: Northern MI
Posts: 117
Not sure if this helps, but I had a similar problem on a 1985 Olds Cutlass when the body ground from the battery was bad.
Adam96Z is offline   Reply With Quote
Old 06-18-2017, 08:17 PM   #7
Registered User
 
Join Date: Jun 2017
Posts: 1
Re: 96 Z28 headlights not working. need help.

[Quote = mattoney01; 6177839] Usted puede tener un cortocircuito en el cableado en alguna parte. Tengo 96 z28, así y tengo problemas con mis luces. Cada vez que vuelvo interruptor de los faros de los faros trabajar pero no hay otras luces funcionan. Mis luces traseras, luces de esquina, faros antiniebla, y mi luz del tablero son todo lo posible. [/ Quote]


Hi, I have the same problem, how do I solve it?
Mario Ceron is offline   Reply With Quote
Old 06-18-2017, 08:46 PM   #8
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 45,792
Re: 96 Z28 headlights not working. need help.

Quote:
Originally Posted by Mario Ceron View Post
[Quote = mattoney01; 6177839] Usted puede tener un cortocircuito en el cableado en alguna parte. Tengo 96 z28, así y tengo problemas con mis luces. Cada vez que vuelvo interruptor de los faros de los faros trabajar pero no hay otras luces funcionan. Mis luces traseras, luces de esquina, faros antiniebla, y mi luz del tablero son todo lo posible. [/ Quote]


Hi, I have the same problem, how do I solve it?
What year, what model? They are not all the same
Injuneer is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need Help swapped gas tank 1998 to 2000 no preasure Deadbolt24 LS1 Based Engine Tech 1 01-19-2015 02:29 PM
Advanced Lightong Technology - Laser Headlights Injuneer Advanced Tech 0 01-15-2015 03:49 PM
odds and ends CaRParts102 Parts For Sale 0 12-06-2014 09:45 AM
New! Total Blackout (or colors/CF) Decal Kit for 2010-13 Camaro @PFYC-PartsForYourCar PFYC Supporting Vendor Group Purchases and Sales 0 12-04-2014 12:56 PM
Quick Bose Question Rich_z28 Car Audio and Electronics 2 08-27-2002 01:20 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:36 PM.


Copyright © 1996-2017 CamaroZ28.com. All rights reserved. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.