Runs better when MAF Disconnected.. - CamaroZ28.Com Message Board

3rd Gen / L98 Engine Tech 1982 - 1992 Engine Related

Runs better when MAF Disconnected..

Reply

 
Old 11-06-2003, 01:33 AM
  #1  
Registered User
Thread Starter
 
Join Date: Nov 2002
Location: SouthSideCali
Posts: 281
Runs better when MAF Disconnected..

My car runs better when the MAF is disconnected, what would cause this? My MAF was hanging bout 2 months ago and was 1 of the 5 pins got ate up by my alternator band.

Any help on whats goin on here?
Kuruption562 is offline  
Reply With Quote
Old 11-06-2003, 11:22 AM
  #2  
Registered User
 
Join Date: May 1999
Location: Pittsburgh, PA
Posts: 301
My buddy has a 96 Mustang. He left his MAF unplugged by accident for a run down the track. It was his best time ever.

Don't know what to tell you. I just remember when I had my IROC, I had the most problems trying to get my car to run right because of that stupid code 33.
demonspeed is offline  
Reply With Quote
Old 11-06-2003, 06:25 PM
  #3  
Registered User
 
Join Date: Feb 2003
Location: Virginia
Posts: 1,602
is the car showing any codes? if not,i think the MAF might be bad
Rice Killer87 is offline  
Reply With Quote
Old 11-06-2003, 06:29 PM
  #4  
Registered User
 
Join Date: Feb 2003
Location: NJ
Posts: 354
Car runs better? MAF is probably bad, might need to go ahead and replace that

(Goes out to disconnect MAF and cruise with 10 more HP )
Garage Inc. is offline  
Reply With Quote
Old 11-06-2003, 11:19 PM
  #5  
Registered User
 
slayer6x6's Avatar
 
Join Date: Oct 2002
Location: Drexel Hill, Pa
Posts: 1,870
Yes, you have a bad maf sensor. That is actually a pin point test for a map sensor, to disconnect it and see if the engine runs better. Give it a good visual before you toss it. I hope the screens are still on there
slayer6x6 is offline  
Reply With Quote
Old 11-06-2003, 11:50 PM
  #6  
Registered User
Thread Starter
 
Join Date: Nov 2002
Location: SouthSideCali
Posts: 281
ok, i went the the local kragen, i asked to see the Mass Air Flow Sensor and they brought out the whole big peice that goes under the little sensor connects to. All i need is the sensor that connects into it, comin from the wires n all that cuz 2 of the little pins got ate up by my alternator band. I dont think i need the whole peice.

What do i ask for when i try to get the piece?
Kuruption562 is offline  
Reply With Quote
Old 11-07-2003, 04:48 PM
  #7  
Registered User
 
RedIrocZ-28's Avatar
 
Join Date: Nov 2000
Location: Grandville/ Grand Rapids, Michigan
Posts: 1,023
You can't get the plug only, you HAVE to get the whole thing. Trust me, I know. Dont even try to get the plug part. If you do try to get one from a junkyard car, don't even think about removing the plug section, put the whole thing in. If you do try to remove it, 99% chance you'll break it.
RedIrocZ-28 is offline  
Reply With Quote
Old 11-07-2003, 10:07 PM
  #8  
Registered User
Thread Starter
 
Join Date: Nov 2002
Location: SouthSideCali
Posts: 281
"Mr Trust me" I found the connector peice for $17 at my Local Napa Auto parts.
Kuruption562 is offline  
Reply With Quote
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
DirtyDaveW
Forced Induction
13
12-01-2016 06:37 PM
pete53
LT1 Based Engine Tech
8
12-09-2014 08:31 AM
formula218
Parts For Sale
1
12-02-2014 05:27 PM
BIGCOWL-IMP
Midwest
0
11-21-2014 10:40 AM
RedLineRev
LT1 Based Engine Tech
17
01-23-2003 04:51 PM


Thread Tools
Search this Thread
Quick Reply: Runs better when MAF Disconnected..


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.