LT1 Based Engine Tech 1993-1997 LT1/LT4 Engine Related

94 trans am running rough and popping

Old 03-03-2019, 03:40 PM
  #1  
Registered User
Thread Starter
 
Join Date: Mar 2019
Posts: 5
94 trans am running rough and popping

My 94 trans am is running rough and popping. I have replaced the opti spark, coil, computer, plugs and wires,
94tran is offline  
Old 03-03-2019, 07:39 PM
  #2  
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 67,285
Re: 94 trans am running rough and popping

When is it running rough and popping - cold idle (open loop), hot idle (closed loop), on the road cruising at moderate load, at WOT, all of the above?

At any point have you scanned it for codes or checked the fuel pressure? How old are the O2 sensors? Is the engine basically stock, or modified? If modified, what has been done to it?

What led you to replace those specific parts? Particularly the “computer”.... they rarely fail.
Injuneer is offline  
Old 03-03-2019, 07:48 PM
  #3  
Registered User
Thread Starter
 
Join Date: Mar 2019
Posts: 5
Re: 94 trans am running rough and popping

Originally Posted by Injuneer View Post
When is it running rough and popping - cold idle (open loop), hot idle (closed loop), on the road cruising at moderate load, at WOT, all of the above?

At any point have you scanned it for codes or checked the fuel pressure? How old are the O2 sensors? Is the engine basically stock, or modified? If modified, what has been done to it?

What led you to replace those specific parts? Particularly the “computer”.... they rarely fail.
i honestly was just replacing what i thought could be the problem, it does it some on cold start but mostly when its warm. When i pulled the plugs out they were covered in gas. My next step was going to be replacing the injectors
94tran is offline  
Old 03-04-2019, 09:53 AM
  #4  
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 67,285
Re: 94 trans am running rough and popping

Sounds more like a problem with running rich - many possible causes..... excessive fuel pressure, leaking fuel pressure regulator, faulty O2 sensors (or faulty wiring), exhaust leaks before the O2 sensors, faulty coolant temp sensor, etc.

Back to basics....have you scanned for codes? Have you checked the fuel pressure? You have to answer the questions if you want useful help.

Data log using Scan9495 could help identify the problem. Download free software to laptop, buy or build a cable, log the PCM from cold start thru a WOT pull. Post a .pdf file of the log, and I'll review it for you. A lot less expensive than playing “parts replacement roulette”.

https://www.camaroz28.com/forums/com...95-lt1-874306/




Last edited by Injuneer; 03-04-2019 at 09:57 AM.
Injuneer is offline  
Old 03-04-2019, 11:37 AM
  #5  
Registered User
Thread Starter
 
Join Date: Mar 2019
Posts: 5
Re: 94 trans am running rough and popping

I have not done a compression test but i will do that, when i scanned it i got a a 1 and 3 cylinder miss
94tran is offline  
Old 03-04-2019, 01:16 PM
  #6  
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 67,285
Re: 94 trans am running rough and popping

Originally Posted by 94tran View Post
I have not done a compression test but i will do that, when i scanned it i got a a 1 and 3 cylinder miss
Didn’t ask about compression test. And there is no misfire codes in 94 OBD-1. Misfire detection was added in 1996 as part of OBD-2. Were you using a Tech-2 to access PCM data?

Last edited by Injuneer; 03-04-2019 at 04:03 PM.
Injuneer is offline  
Old 03-04-2019, 05:41 PM
  #7  
Registered User
Thread Starter
 
Join Date: Mar 2019
Posts: 5
Re: 94 trans am running rough and popping

I got the car from my brother inlaw and he took it to a shop and they scanned it and told him that it was misfiring on 1 and 3 so he replaced the plugs, wires and opti spark. None of this fixed it so he got tired of messing with it so i bought it. I put a computer in it and changed the plugs out again because they were fouled out, the car misses and pops but if you rev it up it will rev out. I have noticed that the header gaskets need to be replaced
94tran is offline  
Old 03-04-2019, 07:16 PM
  #8  
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 67,285
Re: 94 trans am running rough and popping

There is NO misfire detection on the 93-95 OBD-1 LT1. Misfire detection requires a crank position sensor, and the 93-95 engine doesn’t have one. Not much more I can do to help if you don’t believe me.
Injuneer is offline  
Old 03-04-2019, 07:30 PM
  #9  
Registered User
 
Join Date: Jun 2003
Posts: 866
Re: 94 trans am running rough and popping

OP

before you start throwing parts at it, some of the new ones can likely be bad, scan the car using the free software scan9495.

injuneer is VERY knowledgeable but he or anyone can not help over the internet without solid diagnostic data

you mention you have bad exhaust (header) gaskets.....fix those first. exhaust leak will make the car run rich

also check for things like a cracked intake elbow. Unmetered air entering motor after MAF will make the car run pig rich

Once you get obvious issues fixed, start car in the dark and look very closely at spark plug boots/wires...is there a light show? if so you have bad plug wire(s). Misting them with a little water can help reveal plug wire arc. You may (read should) put the car up on ramps and look from below so you can see ALL of the plug bot. If plug boot has the metal heat shield on it, remove it as the arc can be between the inside of it and boot...making it impossible to see

would also be VERY helpful to simply check fuel pressure to confirm it is not stupid high......or low
Chimera96 is online now  
Old 03-04-2019, 07:54 PM
  #10  
Registered User
Thread Starter
 
Join Date: Mar 2019
Posts: 5
Re: 94 trans am running rough and popping

I never said i dident believe you, you asked why i replaced all of the parts so i was just letting you know what the guy that i got the car from told me
94tran is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
tnorm077
LT1 Based Engine Tech
4
06-23-2017 02:45 PM
mvvette97
LT1 Based Engine Tech
6
04-25-2009 09:16 AM
mjeep4x4
3rd Gen / L98 Engine Tech
1
09-22-2006 04:23 AM
Cash
LT1 Based Engine Tech
10
07-06-2006 09:51 AM
BigTed187
LT1 Based Engine Tech
5
10-15-2003 03:56 PM


Thread Tools
Search this Thread
Quick Reply: 94 trans am running rough and popping


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.