General 1967-2002 F-Body Tech For general F-Body discussion that does not fit in any other forum.
For F-Body Technical/Information Discussion ONLY

1994 z28 lt1 misfiring

Old 11-23-2014, 08:32 PM
  #1  
Registered User
Thread Starter
 
Join Date: Nov 2014
Posts: 5
1994 z28 lt1 misfiring

Okay so my car has been misfiring, backfiring, stumbling lacking acceleration for a few days, changed ignition coil and now it won't start at all, a mechanic said my starter was bad, the bolts had broke off in the block but I had them fixed at a shop and he said I'll be needing a new one cause it got messed up driving it how it was. I need help figuring out why it's doing the things it's doing instead of throwing new parts at it.
Dyoung_Z28 is offline  
Old 11-23-2014, 09:10 PM
  #2  
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 67,208
Re: 1994 z28 lt1 misfiring

Have you scanned it for codes?

Have you checked the fuel pressure?

Have you checked for a plugged cat?

How old are the plugs and have the injectors ever been cleaned??
Injuneer is offline  
Old 11-24-2014, 03:11 PM
  #3  
Registered User
Thread Starter
 
Join Date: Nov 2014
Posts: 5
Re: 1994 z28 lt1 misfiring

How can I check for a plugged cat.
Only codes that popped up when it did get scanned was crank sensor
I don't have anything to check fuel pressure. I have new plugs new optispark and new wires
Dyoung_Z28 is offline  
Old 11-24-2014, 03:29 PM
  #4  
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 67,208
Re: 1994 z28 lt1 misfiring

Check for a plugged cat by measuring the pressure in the exhaust system before the cat. An exhaust shop can connect a pressure gauge to the O2 sensor bung to measure the pressure.

94 does not have a crank sensor. The crank sensor was not added until 1996, to detect misfires.

Did you possibly get DTC 16 and/or DTC 36 for the cam position sensor in the Opti?

Last edited by Injuneer; 11-24-2014 at 03:32 PM.
Injuneer is offline  
Old 11-25-2014, 09:45 AM
  #5  
Registered User
Thread Starter
 
Join Date: Nov 2014
Posts: 5
Re: 1994 z28 lt1 misfiring

I'll update you on everything. So I changed the optispark and ignition coil and car won't start just cranks and send a loud pop out the exhaust pipes. I think maybe it's a timing issue or something. I took everything back about but I can't get the timing cover off its something holding it in at the bottom
Dyoung_Z28 is offline  
Old 11-25-2014, 02:04 PM
  #6  
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 67,208
Re: 1994 z28 lt1 misfiring

Are you sure you indexed the splined Opti drive shaft correctly to the cam sprocket? Are you sure you have all the plug wires in the correct order?

http://shbox.com/1/93-94_opti.jpg

http://shbox.com/1/opti.jpg
Injuneer is offline  
Old 11-25-2014, 02:29 PM
  #7  
Registered User
Thread Starter
 
Join Date: Nov 2014
Posts: 5
Re: 1994 z28 lt1 misfiring

Is that spline pointing downwards? 8 can't see inside the timing cover, and the opti spline is placed at an angle




Originally Posted by Injuneer View Post
Are you sure you indexed the splined Opti drive shaft correctly to the cam sprocket? Are you sure you have all the plug wires in the correct order?

http://shbox.com/1/93-94_opti.jpg

http://shbox.com/1/opti.jpg
Dyoung_Z28 is offline  
Old 11-25-2014, 04:31 PM
  #8  
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 67,208
Re: 1994 z28 lt1 misfiring

The location of the spline notch varies with the position of the crank/cam in their rotation.

Depending on what Opti you purchased, the splined shaft may be removable from the back of the Opti, like it is with the OEM units. Then you could put the shaft correctly into the cam sprocket, being sure not to force it, then align the same "odd tooth" setup on the Opti end of the shaft with the splines in the Opti. Both ends of the factory shaft are keyed with the same spline arrangement. Doing it that way, it's easier to see what you are doing.

What brand Opti did you buy? Did you loc-tite the rotor screws before the install? Some of the ebay cheap Chinese ripoffs are often dead out of the box. All of them have a tendancy for the rotor screws to back out over time.
Injuneer is offline  
Old 11-25-2014, 05:26 PM
  #9  
Registered User
Thread Starter
 
Join Date: Nov 2014
Posts: 5
Re: 1994 z28 lt1 misfiring

I got mines from oriellys suppose to be oem. I didn't force it in the camshaft but in order for it to line up I had to spin the one on the opti
Dyoung_Z28 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Red Hawk 94
General 1967-2002 F-Body Tech
2
03-18-2019 04:03 PM
Noenav
Cars For Sale
2
03-01-2019 07:38 AM
cmdeshon
LT1 Based Engine Tech
2
01-04-2015 11:15 AM
thenewkid
New Member Introduction
5
11-27-2014 09:41 AM
94z28jbw
Site Help and Suggestions
2
09-08-2002 03:22 PM


Thread Tools
Search this Thread
Quick Reply: 1994 z28 lt1 misfiring


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.