3rd Gen / L98 Engine Tech 1982 - 1992 Engine Related

1989 iroc z with a 305 tpi

Old 04-15-2009, 05:55 AM
  #1  
Registered User
Thread Starter
 
Join Date: Apr 2009
Posts: 1
1989 iroc z with a 305 tpi

Im workin on a 89 camaro for a buddy of mine and it has no fuel pressure at the sradder valve or at the fuel filter but i just started working on it and when i got to it some one had dropped the fuel tank changed the fuel pump and the fuel filter but when they put the tank back in they kinked of the 3 steal lines so they cut them and spliced them together with rubber hose i was wondering if any one thought that the reason i have no fuel pressure at the filter is because they got the lines mixed up and the supposed feed line is really a return line just a thought figured maybe some one on here could help me out thanks

Last edited by BIGB21; 04-15-2009 at 05:59 AM.
BIGB21 is offline  
Old 04-15-2009, 11:42 AM
  #2  
Registered User
 
Join Date: Mar 2002
Location: Byhalia Ms, just south of Memphis
Posts: 381
check the FP relay first. its next to the brake booster with the MAF power relay and MAF burn off relay. it looks a tad diff than those 2. reach over and see if it clicks when you hit the key, if it does then you have a FP issue, if it dosent then you have a FP relay issue.
quickchicken is offline  
Old 04-29-2009, 10:26 AM
  #3  
Registered User
 
teke184's Avatar
 
Join Date: Sep 1998
Location: US 1 Mile Marker 52 in the Florida Keys
Posts: 8,328
is the fuel pump even priming?

kneel down next to the rear end, have someone switch the key ON, but not start the car.

you'll hear it prime then shut off.

if that doesn't happen...you know you have wiring issues first and foremost.
teke184 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
G-BODYT56
Parts For Sale
2
09-25-2015 05:10 AM
Matt Dreessen
Fuel and Ignition
1
09-09-2015 09:58 PM
gonzo275rltw
3rd Gen / L98 Engine Tech
4
09-07-2015 04:46 PM
gonzo275rltw
LT1 Based Engine Tech
4
09-05-2015 06:26 PM
gonzo275rltw
LS1 Based Engine Tech
2
09-05-2015 06:24 PM


Thread Tools
Search this Thread
Quick Reply: 1989 iroc z with a 305 tpi


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.