V6 Tech 1967-2002 V6 Engine Related

95 camaro power issue?

Old 04-07-2011, 03:01 PM
  #1  
Registered User
Thread Starter
 
Join Date: Dec 2010
Posts: 3
Exclamation 95 camaro power issue?

i have a 95 Camaro 3.4L. Yesterday and today i noticed that when i turned my headlights on my gauges reacted weird. this also happens when i pushed the brake. And if i turn my radio up to like 30(it goes to 50) it just shuts my radio off then it comes back on, and repeats until i turn my radio down. please please please some one tell me what is going on!! what is my problem? where should i start? I have tried braking with my lights and radio off and it still does it. Same with the lights.
jeffrox13 is offline  
Old 04-09-2011, 09:06 PM
  #2  
Registered User
 
evoxm9's Avatar
 
Join Date: Apr 2011
Location: Walden CO
Posts: 28
Re: 95 camaro power issue?

id start with having the alternator tested, and if its good then get a good wiring schematic and make sure all wires go were the supposed to and have proper fusses
evoxm9 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dbusch22
LT1 Based Engine Tech
2
01-05-2015 07:14 PM
cmdeshon
LT1 Based Engine Tech
2
01-04-2015 11:15 AM
NewsBot
2010 - 2015 Camaro News, Sightings, Pictures, and Multimedia
0
12-17-2014 02:50 PM
PFYC
Supporting Vendor Group Purchases and Sales
0
12-01-2014 08:08 AM
Alucard
Site Help and Suggestions
3
07-29-2002 10:30 PM


Thread Tools
Search this Thread
Quick Reply: 95 camaro power issue?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.