Ls piston slap sound'system FIX ??? - CamaroZ28.Com Message Board

LS1 Based Engine Tech LS1 / LS6 / LS2 / LS3 / LS7 Engine Tech

Ls piston slap sound'system FIX ???

Old 12-03-2016, 03:08 PM
  #1  
Registered User
Thread Starter
 
Join Date: Nov 2016
Posts: 7
Lightbulb Ls piston slap sound'system FIX ???

Had piston slap sound's and hard engine rocking re-start after engine up to full temperature. Took PCV out and ran 6 ounces of CRC through intake and slapping noise GONE, also engine rocking on full temperature re-starting GONE
StephenMessina1 is offline  
Old 12-03-2016, 06:46 PM
  #2  
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 66,983
Re: Ls piston slap sound'system FIX ???

You sure it wasn't carbon buildup in the combustion chambers, and causing detonation? "Top oil" through the intake is a general cure for that. I had a 455 HO Pontiac in a 1973 Grand Prix. One day I started it and it sounded like someone was hitting the pistons with a 3-pound hammer. Had it towed, mechanic said "watch this", poured in top oil, carbon blew out the exhaust and noise completely disappeared.

Piston slap would not cause the engine to "rock" when started hot. But excessive combustion pressures might.
Injuneer is offline  
Old 12-03-2016, 10:21 PM
  #3  
Member
 
GaryDoug's Avatar
 
Join Date: Jul 2010
Location: Florida West Coast
Posts: 1,210
Re: Ls piston slap sound'system FIX ???

I've read that carbon buildup is one of the possible causes of piston slap, or at least it worsens it. My 98 didn't have piston slap when new, not until about 10 years ago. Maybe I should try that stuff. I see that is applied three ways and two are in the gas and in the oil. Is there a possibility that this would cause my rear crank seal to start leaking again?

Last edited by GaryDoug; 12-03-2016 at 10:29 PM.
GaryDoug is offline  
Old 12-04-2016, 09:32 AM
  #4  
Registered User
Thread Starter
 
Join Date: Nov 2016
Posts: 7
Re: Ls piston slap sound'system FIX ???

Might have to try that one also.Tick,tap,click is back on cold start then goes away when up to full temp.Going to flood intake with CRC to the point it stalls , after that if not cured,may try O-Rings at the oil sump ( GM bulletin- one of many on the subject )
StephenMessina1 is offline  

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.