Pinging After Cam Install? - CamaroZ28.Com Message Board

LT1 Based Engine Tech 1993-1997 LT1/LT4 Engine Related

Pinging After Cam Install?

Reply

 
Old 08-29-2002, 07:42 AM
  #1  
Registered User
Thread Starter
 
Join Date: Jul 2000
Location: Allentown-Quakertown-Whitehall-Pottstown, PA
Posts: 123
Post Pinging After Cam Install?

what could cause pinging after my cam install? A good shop did my install, now they are trying to find this out, what could it be that is causing the problem.

Car has new wires, plugs, opti. Has steady fuel pressure. The only mods are headers and lt4 hot cam. When the car is given 1/2 throttle it will ping. Can the timing be off possibly..what other ideas.

-Corey

------------------
Electron Blue '94 Trans Am w/ '98 Front End

!CAGS, Hooker LT Headers Ghetto Intake, Drilled/Slotted Rotors, Shortened Shifter w/ B&M Polished T-Handle, SLP Ram Air H.O. Hood, 17x9 Firehawk Wheels, Blue Taylor 8mm Custom Length Wires w/ Made For You OVC Wire Looms, 5" Autometer Tach w/ Shift Lite, 2 1/6" A/F Guage In Vent, 2 1/6" Digital Oil Temp Guage In Vent.

Latest mods finished: Stock replacement timing chain, new opti, lt4 hot cam kit, custom y-pipe, stock ss/ws6 catback (99+ style).
GigaMp3z is offline  
Reply With Quote
Old 08-29-2002, 10:37 AM
  #2  
Registered User
Thread Starter
 
Join Date: Jul 2000
Location: Allentown-Quakertown-Whitehall-Pottstown, PA
Posts: 123
Post

TTT.

------------------
Electron Blue '94 Trans Am w/ '98 Front End

!CAGS, Hooker LT Headers Ghetto Intake, Drilled/Slotted Rotors, Shortened Shifter w/ B&M Polished T-Handle, SLP Ram Air H.O. Hood, 17x9 Firehawk Wheels, Blue Taylor 8mm Custom Length Wires w/ Made For You OVC Wire Looms, 5" Autometer Tach w/ Shift Lite, 2 1/6" A/F Guage In Vent, 2 1/6" Digital Oil Temp Guage In Vent.

Latest mods finished: Stock replacement timing chain, new opti, lt4 hot cam kit, custom y-pipe, stock ss/ws6 catback (99+ style).
GigaMp3z is offline  
Reply With Quote
Old 08-29-2002, 11:21 AM
  #3  
Registered User
 
Join Date: Jul 2002
Location: GA
Posts: 177
Post

I resently installed an LT4 Hotcam and we had some bad pinging at ~2000RPM come to find out the rockers needed adjustment. Turn the crank manually and tighten the rockers one by one as the come up 2/3 of the way. Hope this helps but it may not be your answer.

------------------
94 TA 25th Anniversary
Moroso CAI,Vortech Elbow,Ported MAF,MSD box,100 Shot NOS N20, TPIS Headers & Y-Pipe, FLO catback 3inch, 4L60-E w/shift kit, 160 stat, Crappy Tires
[email protected]
Shankels94TA is offline  
Reply With Quote
Old 08-29-2002, 11:21 AM
  #4  
Registered User
 
Join Date: Aug 2000
Location: New Britain, CT 06053
Posts: 86
Post

Could they have installed it a tooth advanced?

------------------
1987 Flame Metallic Red IROC-Z Camaro. LT1 motor installed. http://home.attbi.com/~markolc
Markolc is offline  
Reply With Quote
Old 08-29-2002, 06:21 PM
  #5  
Registered User
Thread Starter
 
Join Date: Jul 2000
Location: Allentown-Quakertown-Whitehall-Pottstown, PA
Posts: 123
Post

they just checked the timing cover, and the timing is right on. The roller rockers not being tightened right could cause this problem?

thanks,
corey
GigaMp3z is offline  
Reply With Quote
Old 08-29-2002, 08:43 PM
  #6  
Registered User
 
Join Date: Mar 2000
Posts: 186
Post

Audible ping - like marbles in a tin can? That is not good. Hook up Diacom/TTS/whatever and monitor your knock retard and O2 read outs. If you are running excessively lean, it'll knock. If the car is pulling 15 degrees of timing (max) and it's still pinging, there is something majorly wrong - cam timing definitely comes to mind as does misadjusted rockers.

-Alex
AlexA is offline  
Reply With Quote
Old 09-04-2002, 08:08 PM
  #7  
Registered User
Thread Starter
 
Join Date: Jul 2000
Location: Allentown-Quakertown-Whitehall-Pottstown, PA
Posts: 123
Post

i know the post is not at the top..but yes the ping is audible. Roller Rockers might not be tightened right?

I hope its something as simple as that.

-Corey

------------------
Electron Blue '94 Trans Am w/ '98 Front End

!CAGS, Hooker LT Headers Ghetto Intake, Drilled/Slotted Rotors, Shortened Shifter w/ B&M Polished T-Handle, SLP Ram Air H.O. Hood, 17x9 Firehawk Wheels, Blue Taylor 8mm Custom Length Wires w/ Made For You OVC Wire Looms, 5" Autometer Tach w/ Shift Lite, 2 1/6" A/F Guage In Vent, 2 1/6" Digital Oil Temp Guage In Vent.

Latest mods finished: Stock replacement timing chain, new opti, lt4 hot cam kit, custom y-pipe, stock ss/ws6 catback (99+ style).
GigaMp3z is offline  
Reply With Quote
Old 02-16-2003, 07:22 PM
  #8  
Registered User
 
Join Date: Aug 2002
Location: Homestead, FL
Posts: 250
Just did a hotcam install also and have pinging.
Did you figure out what your problem was?
max929 is offline  
Reply With Quote
Old 02-18-2003, 08:03 AM
  #9  
Registered User
 
Join Date: Aug 2002
Location: Homestead, FL
Posts: 250
Originally posted by AlexA
Audible ping - like marbles in a tin can? That is not good. Hook up Diacom/TTS/whatever and monitor your knock retard and O2 read outs. If you are running excessively lean, it'll knock. If the car is pulling 15 degrees of timing (max) and it's still pinging, there is something majorly wrong - cam timing definitely comes to mind as does misadjusted rockers.

-Alex
What should the numbers read for the o2 sensors when hooking up scanner?
max929 is offline  
Reply With Quote
Old 02-18-2003, 08:39 AM
  #10  
Registered User
 
Join Date: Oct 2002
Location: Denver
Posts: 860
You need to scan the car and get some o2 readings and knock readings. Sounds like a lean detination problem the worst stress to put on a motor. Be easy on it or else you might have to do a head gasket. Is there any chance you got bad fuel. Down here in Miami/Fort Lauderdale its not to un common to buy water!
94SLUG is offline  
Reply With Quote
Old 02-18-2003, 10:02 AM
  #11  
Registered User
 
Mikey97Z's Avatar
 
Join Date: Nov 2001
Location: West Palm Beach, FL
Posts: 648
Angry

After my recent cam install i heard pinging too! I think it's only on the right side of the engine. But the knock count wasn't moving. I'm hoping the sound is a misadjusted rocker.

Would that cause ping as in detonatin? Or would that just be a valve closing too hard and making a pinglike noise?
Mikey97Z is offline  
Reply With Quote
Old 02-18-2003, 10:19 AM
  #12  
Registered User
 
Join Date: Oct 2002
Location: Denver
Posts: 860
Well if its in the rockers it normaly sounds like CHATTER or TAPING why not pull valve covers and check valve lash. I just broke a rocker stud and thought it was a stuck valve.
94SLUG is offline  
Reply With Quote
Old 02-18-2003, 12:33 PM
  #13  
Registered User
 
Join Date: Aug 2002
Location: Homestead, FL
Posts: 250
Originally posted by 94SLUG
You need to scan the car and get some o2 readings and knock readings. Sounds like a lean detination problem the worst stress to put on a motor. Be easy on it or else you might have to do a head gasket. Is there any chance you got bad fuel. Down here in Miami/Fort Lauderdale its not to un common to buy water!
Possible, althougth I have since filled the tank and put about 65 miles on her and still pinging.
Think I may have to pull the timing cover off to check the timing, which I am not looking forward to.
Question, if the opti is turned before putting it on, but as long as the teeth line up with the spline would it matter that the opti was turned?
max929 is offline  
Reply With Quote
Old 02-18-2003, 12:51 PM
  #14  
Registered User
 
Join Date: Feb 2003
Location: Berea, Ky
Posts: 105
rockers.... its all in the rockers
Calli is offline  
Reply With Quote
Old 02-18-2003, 01:08 PM
  #15  
Registered User
 
Join Date: Aug 2002
Location: Homestead, FL
Posts: 250
Originally posted by Calli
rockers.... its all in the rockers
Wouldn't I hear them tapping? I wish it where the rockers, but somehow don't see how it could be them...but I guess I have to have it checked out.
max929 is offline  
Reply With Quote
Reply
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dbusch22
Forced Induction
6
10-31-2016 11:09 AM
chuyz28
LT1 Based Engine Tech
21
02-19-2015 12:50 AM
Queens94z28
Parts For Sale
3
12-20-2014 09:11 PM
Noenav
General 1967-2002 F-Body Tech
14
12-06-2014 07:35 PM
F(ast)-body
LT1 Based Engine Tech
8
02-26-2003 09:05 AM


Thread Tools
Search this Thread