Comp Cams 918 spring failures !!!! - Page 2 - CamaroZ28.Com Message Board

LS1 Based Engine Tech LS1 / LS6 / LS2 / LS3 / LS7 Engine Tech

Comp Cams 918 spring failures !!!!

Old 07-20-2007, 03:18 AM
  #16  
Registered User
 
Join Date: Aug 2005
Location: Kantuckee Yo'
Posts: 4,406
Maybe the 918 failure threads in LT1/LT4 section should have been "stickied".
wrd1972 is offline  
Old 09-02-2008, 09:33 PM
  #17  
Registered User
 
LaredoZ28's Avatar
 
Join Date: Aug 2006
Location: Encinal, Tx
Posts: 343
would it matter if i have the 918 beehives on my LT1? I recently pulled the valve covers to put new rockers and they all looked great. the ones i have are the yellow ones.
LaredoZ28 is offline  
Old 12-24-2008, 08:31 PM
  #18  
Registered User
 
Join Date: Dec 2008
Posts: 6
comp springs

I just purchashed my first camaro a month ago. I have been detailing it and getting ready to install a clutch. the car has a comp cam with approx 12000 miles on it. The owner recommended that I replace the springs. Is this necessary since they only have 12k on them. I don't have the specs on the cam yet.
VLANDER005 is offline  
Old 03-01-2009, 06:40 AM
  #19  
Registered User
 
Join Date: Feb 2009
Location: cincinnati
Posts: 2
they got me as well
rah rah is offline  
Old 03-01-2009, 06:41 AM
  #20  
Registered User
 
Join Date: Feb 2009
Location: cincinnati
Posts: 2
i just bought a 98 z28 what should be the first performance up grade should i do?
rah rah is offline  
Old 07-18-2009, 11:41 PM
  #21  
Registered User
 
LS1_03's Avatar
 
Join Date: Apr 2002
Location: Hennepin, Illinois
Posts: 697
918 Springs are fine. The batch with the blue stripe are the bad batches. I'm running 918s on my LS1 and I've got a .595i/.605e cam in it. Several thousand miles including me beating the ever lasting **** out of the car at Road America and I'm still motoring along with no probs. Not to mention spinning it to 6,500 at the drag strip as well.
LS1_03 is offline  
Old 07-21-2009, 01:40 AM
  #22  
Registered User
Thread Starter
 
Join Date: Nov 2000
Posts: 858
Ummm check the date of my thread when it was posted and do a search on 918 failures . I had a batch go bad myself as well as many many other people . Comp Cams even addressed the batch failures . I since then have gone with PAC 1518's .
AZ2ENVY is offline  
Old 07-21-2009, 07:07 AM
  #23  
Retired
 
Kraest's Avatar
 
Join Date: Oct 1999
Location: Inside Uranus
Posts: 3,172
Beehive spring are crap anyway.

Get Duals.
Kraest is offline  
Old 07-21-2009, 07:26 AM
  #24  
Registered User
 
Join Date: Jul 1999
Location: Six Mile, SC, USA
Posts: 2,054
Originally Posted by Kraest View Post
Beehive spring are crap anyway.
Get Duals.
LMAO
Shon Herron is offline  
Old 07-21-2009, 09:08 AM
  #25  
Retired
 
Kraest's Avatar
 
Join Date: Oct 1999
Location: Inside Uranus
Posts: 3,172
Originally Posted by Shon Herron View Post
LMAO
Oh yeah!

All the LS1s in my sig had duals. You know why? Because I'd never risk running a single spring on an engine turning that much RPM and power, not to mention the fast ramp rates of modern LS1 cams.


Last edited by Kraest; 07-21-2009 at 09:13 AM.
Kraest is offline  
Old 07-21-2009, 09:44 AM
  #26  
Registered User
 
Join Date: Jul 1999
Location: Six Mile, SC, USA
Posts: 2,054
matter of opinion.
Shon Herron is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RUENUF
Cars For Sale
1
05-25-2016 08:10 PM
RUENUF
South Atlantic
4
03-13-2016 03:39 PM
oldschool
Parts For Sale
16
02-09-2016 09:21 PM
MadMav
Parts For Sale
9
05-25-2015 09:35 PM
BIGCOWL-IMP
Midwest
0
11-21-2014 09:40 AM


Thread Tools
Search this Thread
Quick Reply: Comp Cams 918 spring failures !!!!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.