1995 Camaro bogging down - CamaroZ28.Com Message Board

Go Back   CamaroZ28.Com Message Board > 1967-2002 F-Body Technical Discussion > General 1967-2002 F-Body Tech

Reply Post New Thread
LinkBack Thread Tools Search this Thread
Old 07-15-2013, 02:01 PM   #1
Registered User
Join Date: May 2012
Posts: 10
1995 Camaro bogging down


I have a 1995 Camaro 3.4L. I recently went through and replaced the water pump, the timing cover gasket, and the temperature sensor. Everything went smooth. After the work is done it started right up no problem and idles good. When driving it feels as if the acceleration is not there at all. If I am lucky enough to get up enough speed to get to fourth gear no matter how much gas is given it boggs down and loses speed all by itself. I went through and double checked everything to make sure everything was back where it needed to be. Any suggestions on what I could possibly check from here would be greatly appreciated. Thank you
elite.inc is offline   Reply With Quote
Reply Post New Thread

Similar Threads
Thread Thread Starter Forum Replies Last Post
LT1 and Camaro Parts FS. Jlo Parts For Sale 7 02-03-2015 10:41 PM
LT1 engine swap help needed. 1996 z28 motor/trans into 1995 z28 dbusch22 LT1 Based Engine Tech 2 01-05-2015 08:14 PM
TA steering wheel controls for stereo SLIMJIM Car Audio and Electronics 8 01-07-2003 12:06 PM
Rockford RFX9300 head unit having problems!! slothgrant Car Audio and Electronics 0 08-22-2002 04:01 PM
Silly questions, but an easy one for you install guys. Need help! Chrisdude Car Audio and Electronics 5 07-24-2002 03:25 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -5. The time now is 01:14 AM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.