Electrical Issues - CamaroZ28.Com Message Board


Go Back   CamaroZ28.Com Message Board > 1967-2002 Powertrain Discussion > 3rd Gen / L98 Engine Tech
Sign in using an external account
Register Forgot Password?

Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread
Old 12-28-2009, 08:44 PM   #1
Registered User
 
Join Date: Dec 2009
Location: Tampa
Posts: 1
Electrical Issues

I have 89 iroc 8.7 that i am restoring, After i had the car running good i decided to get into the interior everything was fine till i got to the heater control above the radio were i replaced the blown out bulb and everything went out no headlights fog lights,horn,power trunk,power door locks,radio, dash lights or interior lights I checked all the fuses they are good i replaced the relay next to the master cylinder, still nothing. i verified fuse line after the starter they are good. however when i check the accessory fuse panel with a probe it gives me ground and i send 12 volts in the same line the lights turn on what can be causing this problem, i verified all line tore dash apart all the wires are good. i apreciate any kind of help. Thanks, and if anyone is in tampa/Carrolwood and can come out and fix it i dont have a problem paying i just want it fixed.

Last edited by 1989iroc-z5.7; 12-28-2009 at 08:46 PM. Reason: Added more notes.
1989iroc-z5.7 is offline   Reply With Quote
Old 12-28-2009, 08:44 PM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:17 AM.

 

Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.