CamaroZ28.Com Message Board - Search Results

Search: Posts Made By: salimlt1luv
Showing results 1 to 24 of 24
Search took 0.03 seconds.
Forum: Drivetrain
06-23-2009, 12:24 PM
Replies: 0
Views: 515
Posted By salimlt1luv

trans rebuild needed ?

The car is an auto, it revs up to about 4800 to 5k before shifting into second, and has no accelleration through first... I mean NONE!. Then it changes to 2nd and takes off, but as soon as it has to...
06-23-2009, 12:22 PM
Replies: 3
Views: 613
Posted By salimlt1luv

thanks, I thought that a possibility, havent...

thanks, I thought that a possibility, havent moved her since, but started her a few times and motor still sounds solid.. thinking about doing convert to manual
06-23-2009, 12:19 PM
Replies: 0
Views: 471
Posted By salimlt1luv

auto to manual trans conversion?

I am interested in doing an auto to manual trans conversion. My auto
95Z28 has lost its last battle. Can you tell me the best way to go about this , and also not break my pocket. What is trans...
Forum: Drivetrain
06-23-2009, 12:14 PM
Replies: 3
Views: 703
Posted By salimlt1luv

auto to manual trans conversion

I am interested in doing an auto to manual trans conversion. My auto
95Z28 has lost its last battle. Can you tell me the best way to go about this , and also not break my pocket. What is trans...
Forum: Drivetrain
06-22-2009, 07:53 PM
Replies: 0
Views: 512
Posted By salimlt1luv

Help!! tranny rebuild?/ blown head gaskets?

The car is an auto, it revs up to about 4800 to 5k before shifting into second, and has no accelleration through first... I mean NONE!. Then it changes to 2nd and takes off, but as soon as it has to...
06-22-2009, 07:50 PM
Replies: 3
Views: 613
Posted By salimlt1luv

tranny rebuild?/ head gaskets

The car is an auto, it revs up to about 4800 to 5k before shifting into second, and has no accelleration through first... I mean NONE!. Then it changes to 2nd and takes off, but as soon as it has to...
06-22-2009, 12:26 PM
Replies: 0
Views: 628
Posted By salimlt1luv

high rev/no accelleration in 1st gear HELP!!!

Hello
The car is an auto, it revs up to about 4800 to 5k before shifting into second, and has no accelleration through first... I mean NONE!. Then it changes to 2nd and takes off, but as soon as...
06-16-2009, 04:42 PM
Replies: 6
Views: 19,200
Posted By salimlt1luv

k, I've heard Mobil ! was the best to use, has...

k, I've heard Mobil ! was the best to use, has any one had success with valvolines filter?
06-16-2009, 04:41 PM
Replies: 6
Views: 642
Posted By salimlt1luv

thanks jakekr That's what was recommended to me...

thanks jakekr
That's what was recommended to me as well- Valvo apprs to be the avenue I'll try. Are there any other options
06-16-2009, 02:08 PM
Replies: 6
Views: 19,200
Posted By salimlt1luv

I changed the oil pressure sensor( using shbox...

I changed the oil pressure sensor( using shbox pics...thanks shoebox!!!) I was able to lay atop the engine, find the little ..... and replace it.. I will spare you how in blindly taking it off by...
06-16-2009, 02:03 PM
Replies: 6
Views: 642
Posted By salimlt1luv

I also changed the oil pressure sensor( using...

I also changed the oil pressure sensor( using shbox pics...thanks shoebox!!!) I was able to lay atop the engine, find the little ..... and replace it.. I will spare you how in blindly taking it off...
06-16-2009, 01:58 PM
Replies: 6
Views: 642
Posted By salimlt1luv

thanks everyone... well I came to realize I have...

thanks everyone... well I came to realize I have to use a heavier weight oil...I was recommended to go to a 20w50 and that should take care of the problem.. I already had the oil pump checked and its...
06-15-2009, 04:08 PM
Replies: 6
Views: 19,200
Posted By salimlt1luv

95 LT1 - oil pressure sensor

Help! Ca anyone tell me where the oil press. sensor is on a 95LT1? How easy or hard is it to access and change...My car loses oil pressure all the way to zero!, when I come to idle at intersections...
06-15-2009, 03:23 PM
Replies: 6
Views: 642
Posted By salimlt1luv

Oil Presure problem!!!

new problem arose, no oil pressure...When I took on test drive it spuuterred and ran real rough. Initially oil pressure would rise to about only 20psi!!, I realized a hose from the cover to the...
06-15-2009, 02:37 PM
Replies: 24
Views: 3,223
Posted By salimlt1luv

Hello, Ok the latest replaced water pump and...

Hello,
Ok the latest replaced water pump and did oil change this weekend...Overheating problem solved and car now operating at about 175 to 180....!!!! hooray and thank goodness....! BUT new...
06-11-2009, 04:55 PM
Replies: 24
Views: 3,223
Posted By salimlt1luv

Ok guys, here it is, I ran the car with the...

Ok guys, here it is, I ran the car with the heater on full blast and all the way to the hottest setting. The air never blew hot, at best it got mildly warm. This I attribute to the temp outside. ...
06-10-2009, 08:08 PM
Replies: 24
Views: 3,223
Posted By salimlt1luv

good work guys i will be cautious, and I truly...

good work guys
i will be cautious, and I truly think it really is the water pump.. I'll update tomorrow , if it doesn't cool down then I'll raise it up and chnge the pump on the weekend.
06-10-2009, 04:42 PM
Replies: 24
Views: 3,223
Posted By salimlt1luv

thanks ace I'll try this procedure. I...

thanks ace
I'll try this procedure. I suspected I need to add more coolant to water and I was bleeding the system improperly. So I'll give this a try...
06-10-2009, 03:40 PM
Replies: 24
Views: 3,223
Posted By salimlt1luv

well latest no steam from tailpipe as far as i...

well latest no steam from tailpipe as far as i see, and I'll turn the heat on in the car and see if it works , I'm not seeing any leaks and the oil looks dark but no water or metal in it. I saw...
06-09-2009, 03:14 PM
Replies: 24
Views: 3,223
Posted By salimlt1luv

by the way, what's the best way to know for sure...

by the way, what's the best way to know for sure that the water pump is working. I know it may sound simple but I'm trying everything I can think of at a time. How should it be grounded? Everything...
06-09-2009, 02:51 PM
Replies: 24
Views: 3,223
Posted By salimlt1luv

thanks ss and 6772 here's latest, i ran her...

thanks ss and 6772
here's latest, i ran her for a few this morning and openned both bleeders. when she got up to about 235-240 she started spiting air and steam from the bleeders. Then i revved...
06-08-2009, 07:24 PM
Replies: 24
Views: 3,223
Posted By salimlt1luv

thanks Hal i'll try that tonite and let it run...

thanks Hal
i'll try that tonite and let it run for a few... if it gets too hot I'll shut her down. till i get the water pump... i did notice there is a connector/ plug on the side of the radiator...
06-08-2009, 06:38 PM
Replies: 24
Views: 3,223
Posted By salimlt1luv

thanks, I tried bleeding one the screws but not...

thanks, I tried bleeding one the screws but not both. I di have some water come out and wasn't sure that was a good thing... I will try it again and be more patient. If water is actually moving...
06-08-2009, 12:57 PM
Replies: 24
Views: 3,223
Posted By salimlt1luv

Overheating LT1, help!!

Hello I just bought a 95 Z28. The engine is overheating severely(all the way to 260* if I let it, so I immediately replaced the thermo with a new 180*, and thought my heater core was bad. The heater...
Showing results 1 to 24 of 24


 
Forum Jump

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.