LS1 Based Engine Tech LS1 / LS6 / LS2 / LS3 / LS7 Engine Tech

2002 Z28 radiator fan runs after turn off

Old 02-25-2015, 10:59 AM
  #1  
Registered User
Thread Starter
 
Join Date: Nov 2014
Location: Fort Lauderdale, FL
Posts: 10
2002 Z28 radiator fan runs after turn off

I'm the original owner of my beloved 2002 Z28 & I THOUGHT I knew everything. I had some steering problems & a new mech. replaced rack/pinion/PS pump and did system flush. I drove it home, felt good. I live a mile from the shop. I turned off the car + while standing next to it--I heard a fan running. It stopped after maybe 2 minutes. I NEVER heard the engine do this in the past. Called the mech. and they swear it';s supposed to do this and maybe someone had "disconnected something". I had a Lumina that did that, but never heard this in my Camaro. After 13 years and 120K miles.
It did turn off, but how could the engine be THAT hot? The gauges look fine but why would it start doing that after power steering-related work?
Anybody have any ideas? Should I worry?
mspennyhughes is offline  
Old 02-25-2015, 09:18 PM
  #2  
Member
 
GaryDoug's Avatar
 
Join Date: Jul 2010
Location: Florida West Coast
Posts: 1,228
Re: 2002 Z28 radiator fan runs after turn off

Does your car have the power steering cooler on the engine? It would be a can-shaped device, just below the throttle body, with 4 hoses, connected in the line from the radiator right side to the water pump. Theoretically I suppose, hot power steering fluid could overheat the system.
Attached Thumbnails 2002 Z28 radiator fan runs after turn off-2000-svcman-vol1of3-chassis-ps-cooler.jpg  

Last edited by GaryDoug; 02-25-2015 at 09:25 PM.
GaryDoug is offline  
Old 03-01-2015, 01:54 PM
  #3  
Registered User
Thread Starter
 
Join Date: Nov 2014
Location: Fort Lauderdale, FL
Posts: 10
Re: 2002 Z28 radiator fan runs after turn off

Well, my concerns about the fan coming on were well founded. Wednesday night I drove it 2 miles and the CHECK GAUGES light came on, followed by the engine light gauge going to 260 in a few seconds and I pulled into a Target parking lot.
Called the repair place who IMMEDIATELY denied that it had anything to do with the $1200 steering-related work, but said to have it towed in. I called AAA & had it towed there and Thursday they called and said it needed a water pump. That makes sense...except...I had the water pump replaced 7/7/2014, by my former mechanic. After some thought, I decided not to have it towed back to the guy that replaced the pump and I gave the repair shop the go ahead to replace.
The next day they called and found more problems. They said when they replaced the water pump they said I also need new thermostat, sensor and gasket. They also flushed the system, replaced oil and bled engine. Another $600.
I only drove it home and it seemed okay. Turned it on yesterday and a loud jangling/screechy noise that sounds like it's coming from a belt. I could not face it, so I turned it off and let it sit. I just tried it again and same noise.
It's very hard to find a good repair place. Love my Z28 but it's starting to defeat me.
mspennyhughes is offline  
Old 03-01-2015, 02:11 PM
  #4  
Member
 
GaryDoug's Avatar
 
Join Date: Jul 2010
Location: Florida West Coast
Posts: 1,228
Re: 2002 Z28 radiator fan runs after turn off

The water pump is belt-driven, so the noise could be caused by a failed new pump. Or a failed pulley somewhere on the front of the engine. Get someone to take a look under the hood.
GaryDoug is offline  
Old 03-01-2015, 03:50 PM
  #5  
Registered User
Thread Starter
 
Join Date: Nov 2014
Location: Fort Lauderdale, FL
Posts: 10
Re: 2002 Z28 radiator fan runs after turn off

I dread the thought of taking it back to the place that installed the water pump, but I think-since I spent a total of $1800 with them last week, it's the only course of action.
It's frustrating.
mspennyhughes is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
calaban
LT1 Based Engine Tech
17
03-20-2017 07:36 PM
ro2207
LT1 Based Engine Tech
14
12-04-2014 06:18 PM
ChrisFrez
CamaroZ28.Com Podcast
0
11-30-2014 08:41 AM
cristian1311
General 1967-2002 F-Body Tech
4
11-23-2014 02:22 PM
chevroletfreak
LT1 Based Engine Tech
202
07-04-2005 05:00 PM


Thread Tools
Search this Thread
Quick Reply: 2002 Z28 radiator fan runs after turn off


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.