No crank, no spark, no fuel, no SES light - CamaroZ28.Com Message Board

Fuel and Ignition Fuel Pumps and Systems, Ignition and Spark Systems

No crank, no spark, no fuel, no SES light

Reply

 
Old 07-03-2018, 12:05 AM
  #1  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 3
No crank, no spark, no fuel, no SES light

hello everyone, I am new here and I just purchased a 1994 camaro Z28. But that car does have its issues. The car had no spark, no crank, and no fuel. I have changed my ignition coil and ignition module but still no spark. I have checked all grounds as well. I also have changed the steering column to try and see if this would solve the no crank issue, sadly it did not. I also changed the fuel pump, and when the key is turned to on, I donít hear a prime. Also, when the key is turned to on, half my dash lights donít turn on, like the security and service engine soon light. I have checked to see if it would need a new bulb but even with a new one, no light from those. I was going through the car and found some wires in the back I am unsure of what they go to but I feel like have something to do with my issues. I am unsure how to post those pictures of those wires but they are on the drivers side back quarter panel. I will use a computer later and try and post those pictures but if anyone is able to help about the no spark, no crank, no fuel issue that would be greatly appreciated. By the way I have done my research and could not find any solutions to my problem that is why I am making this post but if you have a sub forum with possible solutions, please link. Thank you everyone
trevorkillbert is offline  
Reply With Quote
Old 07-03-2018, 04:31 PM
  #2  
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 66,792
Re: No crank, no spark, no fuel, no SES light

When you say you replaced the steering column, do you mean the complete column, or just the ignition switch? Did you examine your ignition switch harness connector for loose, melted or burned contacts.

The wires “in the back”... do you mean inside the vehicle or on the underside? The fuel pump harness penetrates the chassis behind the rear seat. The pump and level sender connects on the underside, in front of the rear axle.

Courtesy of Shoebox:

http://shbox.com/1/fuel_pump_wiring.jpg

http://shbox.com/1/fuel_pump_testing.jpg

Do you have a copy of the factory service manual? Free download:

Courtesy of GaryDoug

https://www.mediafire.com/?40mfgeoe4ctti

Have you tried to scan for PCM codes? That will tell you if the PCM is getting power.
Injuneer is offline  
Reply With Quote
Old 07-04-2018, 05:48 PM
  #3  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 3
Re: No crank, no spark, no fuel, no SES light

Originally Posted by Injuneer View Post
When you say you replaced the steering column, do you mean the complete column, or just the ignition switch? Did you examine your ignition switch harness connector for loose, melted or burned contacts.

The wires ďin the backĒ... do you mean inside the vehicle or on the underside? The fuel pump harness penetrates the chassis behind the rear seat. The pump and level sender connects on the underside, in front of the rear axle.

Courtesy of Shoebox:

http://shbox.com/1/fuel_pump_wiring.jpg

http://shbox.com/1/fuel_pump_testing.jpg

Do you have a copy of the factory service manual? Free download:

Courtesy of GaryDoug

https://www.mediafire.com/?40mfgeoe4ctti

Have you tried to scan for PCM codes? That will tell you if the PCM is getting power.

I have tried scanning for codes and without the SES light, I do not know what codes are showing. I also thought the pcm might have been bricked so I pulled one from a 94 Buick road master to try for spark, still nothing. About the steering column, I replace the whole steering column from a 94 firbird
trevorkillbert is offline  
Reply With Quote
Old 07-04-2018, 08:54 PM
  #4  
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 66,792
Re: No crank, no spark, no fuel, no SES light

If you pulled the power to the PCM, you lost any stored codes. SES light working or not does not affect the ability to pull codes with an OBD-1 scanner. In fact, one of the codes is for the SES light circuit. 94 needs the scanner. Last year you could flash codes on the SES light, by shorting the DLC pins was 93.

The point in trying the scanner was to see if it could communicate with the PCM. If it does, you have verified power to the PCM, whether there are codes or not. What kind of scanner do you have?

You need to trace the ignition circuit to find out how far from the battery the 12 Volts is getting. This is a 95 ignition switch schematic, and a 95 starter circuit schematic. Virtually identical to 94. Note the use of fusible links at the red plastic battery “+” terminal box.

Courtesy of Shoebox

http://shbox.com/1/ignswschematic.jpg

http://shbox.com/1/starter_charging_95.jpg


You can test the fuel pump circuit, bypassing the relay and interlock to the PCM/VATS by connecting 12 Volts to the fuel pump prime connector next to the PCM:

http://shbox.com/1/fuel_pump_prime.jpg
Injuneer is offline  
Reply With Quote
Old 07-05-2018, 12:17 AM
  #5  
Registered User
Thread Starter
 
Join Date: Jul 2018
Posts: 3
Re: No crank, no spark, no fuel, no SES light

I had just a cheap scanner from auto zone 😂 but thank you I will be getting back you once I try these
trevorkillbert is offline  
Reply With Quote
Old 07-05-2018, 10:19 AM
  #6  
Registered User
 
Join Date: Jul 2009
Posts: 94
Re: No crank, no spark, no fuel, no SES light

According to the 1994 Service Manual, this car has a Theft Protection Module that reads the resistance of the key pellet like on later models with a BCM. It may be possible the Theft Protection Module is bad. Changing the column with a different ignition switch and key could also cause the symptoms of no spark, no fuel and no crank, wouldn't it. May also want to check fuses 4 & 5 in the IP Fuse Block for the power supply to the module. I've attached schematics from 94 service manual for the Theft Protection System that may help.
Attached Files
File Type: pdf
1994 TheftProtectionSys.pdf (79.8 KB, 1 views)

Last edited by peterpar; 07-05-2018 at 10:39 AM.
peterpar is offline  
Reply With Quote
Old 07-05-2018, 10:47 AM
  #7  
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 66,792
Re: No crank, no spark, no fuel, no SES light

Shoebox has a guide to the PASS-Key II system. Unfortunately, with the “SECURITY” light not coming on in bulb check position, diagnosis is somewhat hampered.

4th Gen LT1 F-Body Tech-PassKey/VATS
Injuneer is offline  
Reply With Quote
Old 07-05-2018, 10:57 AM
  #8  
Registered User
 
Join Date: Jul 2009
Posts: 94
Re: No crank, no spark, no fuel, no SES light

After looking deeper into the IP fuses, circuit # 4 and 5 controls not only the Theft Protection Module, but the PCM, Fuel Pump and Instrument cluster. I would check these fuses first. This may explain no lights or codes. The security light gets a ground from the Theft Protection Module to energize the dash light if the module has power applied. The drawings do not show that the light is getting a ground path from any other source for the test bulb portion of the ignition on. Therefore I'm assuming when the ignition switch is turned to the on position, the module is powered on and a timed relay within the module closes the ground contact to energize the light for the test. If this is the case and the module has no power applied or is bad, the light test function wouldn't operate along with the fuel enable and starter circuits.
Attached Files
File Type: pdf
1994 IP Fuse Block #5.pdf (41.1 KB, 1 views)
File Type: pdf
1994 IP Fuse Block #4.pdf (45.9 KB, 1 views)
File Type: pdf
1994 Security Light.pdf (44.3 KB, 0 views)

Last edited by peterpar; 07-05-2018 at 02:31 PM.
peterpar is offline  
Reply With Quote
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
SSquid
Cars For Sale
0
09-15-2008 09:53 PM
Seal
LT1 Based Engine Tech
0
03-08-2004 03:55 PM
camaroz28_97
LT1 Based Engine Tech
7
08-22-2003 09:09 PM
DracoZK
LT1 Based Engine Tech
6
05-19-2003 05:54 PM
Xride
LT1 Based Engine Tech
10
04-14-2003 03:31 PM


Thread Tools
Search this Thread
Quick Reply: No crank, no spark, no fuel, no SES light


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.