305 tbi running bad and getting worse - CamaroZ28.Com Message Board


3rd Gen / L98 Engine Tech 1982 - 1992 Engine Related

Reply
 
Thread Tools Search this Thread
Old 08-21-2017, 09:31 PM   #1
Registered User
Thread Starter
 
Stevolwevol's Avatar
 
Join Date: Jul 2011
Location: Holland, MI
Posts: 47
305 tbi running bad and getting worse

I replace IAC, TPS, temp sensor. It started with a mild stumble, now it runs rough at start up, loss of power, and generally running very rough. I don't trust driving it since it continues to get worse.
Stevolwevol is offline   Reply With Quote
Old 08-22-2017, 01:15 PM   #2
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 45,789
Re: 305 tbi running bad and getting worse

Have you scanned it for codes? Have you checked the fuel pressure? Have you checked the spark plugs and plug wires? How old is the O2 sensor?

What year is the car?
Injuneer is offline   Reply With Quote
Old 09-02-2017, 09:21 AM   #3
Registered User
Thread Starter
 
Stevolwevol's Avatar
 
Join Date: Jul 2011
Location: Holland, MI
Posts: 47
Re: 305 tbi running bad and getting worse

Quote:
Originally Posted by Injuneer View Post
Have you scanned it for codes? Have you checked the fuel pressure? Have you checked the spark plugs and plug wires? How old is the O2 sensor?

What year is the car?
Plug wires are fine, replaced the plugs, cap, and rotor. They were pretty far gone. It runs better w/tune, but I still get intermittent stumble at low RPM's, between 1 and 2000. I didn't get any codes, mechanic didn't either. Fuel pump seems ok, pressure was fine.
Stevolwevol is offline   Reply With Quote
Old 09-03-2017, 11:56 AM   #4
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 45,789
Re: 305 tbi running bad and getting worse

What about the O2 sensor? Did you check the fuel pressure out on the road, with engine under load, or only at idle? Any signs of running rich or lean due to a leaking/plugged injector? Don't know if the EST module in the distributor can be tested, but that can be a source of rough operation/stumble. Is the any indication of spark knock (detonation) due to a lean condition or running hot? Knock retard can be perceived as roughness.

Does your mechanic have the ability to pull up the long term fuel trims (BLM's) that would indicate if the ECM is having to make huge fuel corrections, in response to a rich or lean condition?
Injuneer is offline   Reply With Quote
Old 09-11-2017, 09:27 PM   #5
Registered User
Thread Starter
 
Stevolwevol's Avatar
 
Join Date: Jul 2011
Location: Holland, MI
Posts: 47
Re: 305 tbi running bad and getting worse

It was a bad EGR valve. I disconnected the vacuum line, and plugged it. It ran fine. I was going to leave it this way, but I picked an EGR for $20 because the box it came in was damaged (normally $42). Works fine now.
Stevolwevol is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 05:03 AM.


Copyright © 1996-2017 CamaroZ28.com. All rights reserved. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.