Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > 1967-2002 Powertrain Discussion > V6 Tech
Sign in using an external account
Register Forgot Password?


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 11-15-2008, 09:18 PM   #1
Registered User
 
Join Date: Nov 2007
Posts: 184
1995 Camaro 3.4l overheating

My car has new thermostat has been flushed and has new thermosensor fans work great and everything. My cars has no water in the oil at all but i see radiator fluid on the bottom of my car idk if this is from when it gets hot and over flows or what. But bout 6 months back my heater leaked but i cut the hoses to that and tied them off it very exspensive to replace i can do it my self but way to lazy it hasnt caused any problems till now can anyone help me out plz ?

thanxs so much guys.
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
Bigrick2324 is offline   Reply With Quote
Old 11-25-2008, 09:49 AM   #2
Registered User
 
Join Date: Mar 2007
Location: Las Cruces, New Mexico
Posts: 24
Where is the coolant coming from? Check your hoses from the water pump and make sure all the clamps are tight. Check your water pump- it may have a leak.
crucescamaro is offline   Reply With Quote
Old 11-25-2008, 09:49 AM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:10 AM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.