Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > 1967-2002 F-Body Technical Discussion > 1967-2002 Specific Technical Discussion > Suspension, Chassis, and Brakes
Sign in using an external account
Register Forgot Password?


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 10-26-2010, 10:02 AM   #1
Registered User
 
Join Date: Oct 2010
Posts: 2
Need help!! After i put new rotor and pads on now i......

I have 98 camaro v6 and few days ago i went and got a new rotor and pads for the car. This is the second time i have done this and its really pretty easy job. Well after i replaced everything at first the pads were sticking a bit so i went and made sure i did everything right and put it all back together. Well now i am getting a wobble almost like the tire gonna fall off.

I keep checking the lug nuts making sure they are tight every time i get out of car but that's not the problem. Its not the type of wobble you get from a warped rotor and at times it not bad and other times its very noticeable. no play in steering,when i turn wheel left to right fast it doesn't shake much but when i go over a bump to where the front end comes up and no weight on front suspension it gets a bad wobble and at times when im driving it will feel like the tire will fall off any second but like i said all are tight


Any help would be great. Thanks in advance
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
seatacwhat is offline   Reply With Quote
Old 10-27-2010, 04:26 PM   #2
Registered User
 
shoebox's Avatar
 
Join Date: Dec 1969
Location: Little Rock, AR
Posts: 26,917
If it's that bad, I would take it all apart and re-check things.
shoebox is offline   Reply With Quote
Old 10-28-2010, 05:05 AM   #3
Registered User
 
DirtyDaveW's Avatar
 
Join Date: Dec 1999
Location: Upstate New York,USA
Posts: 1,720
Send a message via Yahoo to DirtyDaveW
sounds like the 'Hub Centric' wheels are not on there correctly. I would take off the lug nuts, pull the wheel back, put it back on, start all 5 lug nuts and pull them down to finger tight on all 5, then tighten one at the top, tighten one to the bottom, then one on the left, one on the right, etc till all 5 are fully tightened.
If you're already done all this, then I apologize.
__________________
'96 Z28 355 LT1, 3.55 Ford 8.8 differential, PT76GTS Turbo, 127# Bosch Hi Imp Inj, 2-bar Speed Density Turbo Tune
http://www.taekwondoplus.org/z28/Tur...Turboinfo.html
Best:1/4 Mile 11.5@ 127MPH, Full street weight/tires.
DirtyDaveW is offline   Reply With Quote
Old 10-28-2010, 09:14 AM   #4
Registered User
 
km9v's Avatar
 
Join Date: Oct 2004
Location: Beaumont, TX
Posts: 1,294
Garage
Did you lubricate the caliper pins? I had bone dry caliper pins last time I changed pads & rotors on my old 2000 Z. The calipers would stick all the time.
__________________
'11 2SS RS M6
'00 Z28 A4 mostly stock SOLD 03SEP10
'09 GMC Acadia
km9v is offline   Reply With Quote
Old 10-28-2010, 06:56 PM   #5
Registered User
 
n2ceptor's Avatar
 
Join Date: Sep 2002
Posts: 3,481
Were the wheels switched and not put back on the same side they came off??? Could be a balance issue...

Were the rotors cleaned before installation??? They have oily residue on the surface for packaging to control rust...

Was the brake's caliper lubrication points lubed???
__________________
Research your own experience; absorb what is useful, reject what is useless and add what is essentialy your own...Evaluation by others is not a guide. Only the self-sufficient stand alone-most people follow the crowd and imitate... Bruce Lee
n2ceptor is offline   Reply With Quote
Old 10-31-2010, 08:51 AM   #6
Registered User
 
Join Date: Oct 2010
Posts: 2
Re: Need help!! After i put new rotor and pads on now i......

i have done all this have taken apart 3x and back together and still same deal. where are the caliper lubrication points?

tires were not switched,greased up caliper pins the second time had it apart,cleaned oil off rotor before put on car,

Last edited by seatacwhat; 10-31-2010 at 08:54 AM. Reason: to add more info so get better answer
seatacwhat is offline   Reply With Quote
Old 10-31-2010, 08:51 AM
 
Reply Post New Thread

Tags
brakes, steering, suspension, wheel, wobble

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:58 AM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.