Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > 1967-2002 Powertrain Discussion > LT1 Based Engine Tech
Sign in using an external account
Register Forgot Password?
Register Garage Photos Blogs FAQ Members List Social Groups Links Calendar Search Today's Posts Mark Forums Read Z28LiveVendor Directory TSBs


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 11-30-2003, 02:52 AM   #1
Registered User
 
Join Date: Aug 2000
Location: Queens, NY
Posts: 72
Question Really need your help...heater blows cold air and temp gauge does not work!

Hey fellas, a few days ago I posted about my temp gauge not working and how the needle does not move up to show the temp of the car. Well today on my way home, the heater stopped working and it just keeps blowing cool air. It was a 45 minute drive home so the car had plenty of time to heat up to get the hot air going. Funny thing is, when I pulled into my driveway, and the car was idling, the temp gauge needle moved up a little. I noticed that last night too. The needle doesn't move the whole drive home, but a soon as I come to a complete stop in my driveway, it moves up a little bit. Any ideas as to what could be wrong wtih my car? Any help would greatly be appreciated, because it's getting cold around my area and it would really suck to go this whole winter w/o heat and a broken temp gauge. Thanks in advance.

~~Wes
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
__________________
1994 Red Z28 M6
Borla Cat Back, SLP CAI, Pro 5.0 Short Shifter, BMR STB, PowerStop Cross Drilled Rotors, W.W. Super Style Wing
newbielt1 is offline   Reply With Quote
Old 11-30-2003, 02:55 AM   #2
Registered User
 
Join Date: Mar 2003
Location: The Great State of Texas.
Posts: 465
Send a message via AIM to HM Murdock Send a message via Yahoo to HM Murdock
It's kind of a longshot, but your thermostat may be stuck open. With the really cold temps, it'll cool the coolant down so far that it won't heat up hardly at all...Worth a look...Plus, it's only like a 5 dollar part, too.
__________________
1996 H/C 360ci LT1 M6. CC306 and some goodies.
HM Murdock is offline   Reply With Quote
Old 11-30-2003, 02:58 AM   #3
Registered User
 
Join Date: Aug 2000
Location: Queens, NY
Posts: 72
Quote:
Originally posted by HM Murdock
It's kind of a longshot, but your thermostat may be stuck open. With the really cold temps, it'll cool the coolant down so far that it won't heat up hardly at all...Worth a look...Plus, it's only like a 5 dollar part, too.
I was hoping that it might be a stuck thermo, bc that would def be a cheap fix. Would you happen to have a part number and where I would be able to pick one up? I'll def give that a try first. Thanks.

~~Wes
__________________
1994 Red Z28 M6
Borla Cat Back, SLP CAI, Pro 5.0 Short Shifter, BMR STB, PowerStop Cross Drilled Rotors, W.W. Super Style Wing
newbielt1 is offline   Reply With Quote
Old 11-30-2003, 03:19 AM   #4
Registered User
 
Join Date: Mar 2003
Location: The Great State of Texas.
Posts: 465
Send a message via AIM to HM Murdock Send a message via Yahoo to HM Murdock
Here's Autozone's pricing and info:

THERMOSTAT for a
1995 CHEVROLET CAMARO
Normal Stock


HIGH TEMPERATURE 400-195 1 YR $3.99
ORIGINAL EQUIPMENT TEMPERATURE.

AUTOZONE
LOW TEMPERATURE 400-160 1 YR $3.99

AUTOZONE
MEDIUM TEMPERATURE 400-180 1 YR $3.99



I'd do the 180, the bottom one. It gets warm enough to power the heater very sufficiently, but will stay cooler than the 195, while moving.
HM Murdock is offline   Reply With Quote
Old 11-30-2003, 03:22 AM   #5
Registered User
 
Join Date: Aug 2000
Location: Queens, NY
Posts: 72
Thanks for the help Murdock. Any other ideas guys?

~~Wes
__________________
1994 Red Z28 M6
Borla Cat Back, SLP CAI, Pro 5.0 Short Shifter, BMR STB, PowerStop Cross Drilled Rotors, W.W. Super Style Wing
newbielt1 is offline   Reply With Quote
Old 11-30-2003, 03:27 AM   #6
Registered User
 
Join Date: Mar 2003
Location: The Great State of Texas.
Posts: 465
Send a message via AIM to HM Murdock Send a message via Yahoo to HM Murdock
No problem, I doubt both the gauge and the heater would go out at the same time, so logically, I looked at the one part that coud cause both. I hope that does it, as that's an easy install. If I can think of anything else, I'll let you know.
HM Murdock is offline   Reply With Quote
Old 11-30-2003, 04:05 AM   #7
Registered User
 
madwolf's Avatar
 
Join Date: Jul 2001
Location: DeKalb, IL
Posts: 4,580
As far as I know, those Autozone thermostats won't work with the reverse flowing system of the LT1. I know the 160 won't work for sure at least.
madwolf is offline   Reply With Quote
Old 11-30-2003, 09:59 AM   #8
Registered User
 
Join Date: Aug 2000
Location: Queens, NY
Posts: 72
Quote:
Originally posted by madwolf
As far as I know, those Autozone thermostats won't work with the reverse flowing system of the LT1. I know the 160 won't work for sure at least.
Can you please tell me where I can find a thermo that would work for my '94 LT1, since the Autozone ones won't work? I would like to stick with a thermo with the stock specs instead of going with an aftermarket one. Thanks.

~~Wes
__________________
1994 Red Z28 M6
Borla Cat Back, SLP CAI, Pro 5.0 Short Shifter, BMR STB, PowerStop Cross Drilled Rotors, W.W. Super Style Wing
newbielt1 is offline   Reply With Quote
Old 11-30-2003, 10:01 AM   #9
Registered User
 
Join Date: Apr 2001
Location: Old Bridge, NJ 08857
Posts: 649
Pep Boys will have it. It looks longer than the standard thermostats. It'll run about $12-$14.
__________________
1995 Silver Trans am WITH
MAC Headers, K&N FIPK, Borla CatBack, !TB Bypass, BMR STB, BMR Sub Frame Connectors, 160 Stat, Pro 5.0 Shifter, LS1 Brake Upgrade, Poly Trans Mount, SLP Clutch/Pressure Plate, Delphi XM SkyFi2 Radio, 97+ Console, ValentineOne Radar Locator, 2000 T/A Monsoon Radio, 12-Disc Delco CD Changer
Laymaster is offline   Reply With Quote
Old 11-30-2003, 10:25 AM   #10
Registered User
 
Join Date: Feb 2000
Location: Cleveland,OH
Posts: 1,335
This shows the difference between the regular SBC and the LT1 stat.

http://shbox.com/1/tstat.jpg
__________________
95Z A4
anaik is offline   Reply With Quote
Old 11-30-2003, 12:08 PM   #11
Registered User
 
Join Date: Aug 2000
Location: Queens, NY
Posts: 72
Thanks

Quote:
Originally posted by Laymaster
Pep Boys will have it. It looks longer than the standard thermostats. It'll run about $12-$14.
Would you happen to have the part # for the Hypertech 180* thermo? I don't want to go with the 160*, because I need the extra warmth in my heat during the winter. Thanks!

~~Wes
__________________
1994 Red Z28 M6
Borla Cat Back, SLP CAI, Pro 5.0 Short Shifter, BMR STB, PowerStop Cross Drilled Rotors, W.W. Super Style Wing
newbielt1 is offline   Reply With Quote
Old 11-30-2003, 02:58 PM   #12
Registered User
 
Join Date: Nov 2003
Location: Quantico VA, Philly, North NJ
Posts: 101
I belive GM had a Tech Anouncement regarding the Poor Heater proformance in our Vechiles. You might want to check it out.
NJCustoms is offline   Reply With Quote
Old 11-30-2003, 03:37 PM   #13
Registered User
 
Join Date: Feb 2000
Location: Cleveland,OH
Posts: 1,335
Re: Thanks

Quote:
Originally posted by newbielt1
Would you happen to have the part # for the Hypertech 180* thermo? I don't want to go with the 160*, because I need the extra warmth in my heat during the winter. Thanks!

~~Wes
The stock stat is 180*. Just go to a Chevy dealer.
__________________
95Z A4
anaik is offline   Reply With Quote
Old 11-30-2003, 04:29 PM   #14
Registered User
 
Join Date: Nov 2002
Posts: 1,074
Send a message via AIM to Seal
Quote:
Originally posted by NJCustoms
I belive GM had a Tech Anouncement regarding the Poor Heater proformance in our Vechiles. You might want to check it out.
where is that at?
__________________
97 Gunmetal Turbo Trans Am
Seal is offline   Reply With Quote
Old 11-30-2003, 04:33 PM   #15
Registered User
 
Join Date: Jan 2001
Posts: 610
Some Z's came stock with 195* Thermostats, Including mine. Maybe the states with the toughest emissions had the 195's
RCF925 is offline   Reply With Quote
Old 11-30-2003, 04:33 PM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:07 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2010, Crawlability, Inc.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.