Engine noise - CamaroZ28.Com Message Board

Go Back   CamaroZ28.Com Message Board > 1967-2002 Powertrain Discussion > LT1 Based Engine Tech

Closed Thread Post New Thread
LinkBack Thread Tools Search this Thread
Old 09-09-2013, 04:16 AM   #1
Registered User
Join Date: Sep 2013
Posts: 4
Engine noise

I have a '01 Z28 with 5.7L Ls1 132,000 miles. I've only had this car about 3 weeks but only mods that im aware of are headers, slp ram air intake and the stock thermostat was replaced with a 160 degree one. Check engine light comes on and only code indicates secondary air injection sytem malfunction. Apparently the air pump has been completely disconnected and removed which is what is causing the light to come on. I've been told I can have the chip re-tuned so that this doesn't happen which I may do sometime but for now that isnt my biggest issue. When I fist start the car there is a pecking noise that is very noticeable but goes away after awhile. After a google search and reading about some other ppls experience my best guess is piston slap. The only symptoms I notice that are different in my situation vs others with piston slap is that they seem to indicate that the noise goes away rather quickly, like after a min or 2 of warming up whereas mine takes a bit longer. After first start up of the day I can drive about 1.5 miles down the road to the gas station and still hear the pecking if I roll down the windows or open the door, but then if I drive another cpl miles and stop the sound is completely gone. Any ideas of what this might be? If it is piston slap what if anything can be done about it? I just joined this forum and this is my first post, any input or suggestions will be greatly appreciated, thanks!
Marty0503 is offline  
Old 09-09-2013, 10:44 AM   #2
Registered User
shoebox's Avatar
Join Date: Dec 1969
Location: Little Rock, AR
Posts: 27,230
Re: Engine noise

You'll probably get better help posting this in the LS1 forum instead of the LT1 forum.
shoebox is offline  
Old 09-09-2013, 11:36 AM   #3
Registered User
Join Date: Sep 2013
Posts: 4
Re: Engine noise

Thanks, I reposted in the Ls1 forum.
Marty0503 is offline  
Closed Thread Post New Thread

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clank noise after car is parked Fatdog2 General 1967-2002 F-Body Tech 2 02-12-2015 01:24 PM
Question on rear end. jcamaro95lt1 LS1 Based Engine Tech 1 01-24-2015 09:21 AM
Shot power steering system after brief heat up? ro2207 LT1 Based Engine Tech 14 12-04-2014 07:18 PM
Fixed obnoxious rattle in trunk area on convertable squarehead General 1967-2002 F-Body Tech 0 11-21-2014 09:02 PM
Is this amp ok? Omega9 Car Audio and Electronics 2 08-02-2002 01:33 AM

engine noise, ls1, piston slap

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -5. The time now is 12:41 AM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.