Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > 1967-2002 Powertrain Discussion > LT1 Based Engine Tech
Sign in using an external account
Register Forgot Password?
Register Garage Photos Blogs FAQ Members List Social Groups Links Calendar Search Today's Posts Mark Forums Read Z28LiveVendor Directory


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 04-20-2009, 04:43 PM   #1
Registered User
 
Join Date: Apr 2009
Posts: 1
95 LT1 service engine soon light

The light comes on when I start to drive in less than a mile. I know it has a OBD 1, but is there a way to have it diagnosed, it runs great but it is annoying. thanks. Also the brake and ABS inop light is on all the time, but when I move, the low trac light flashes and i here a click with the light under the hood, any ideas on that one, thanks again.
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
church27 is offline   Reply With Quote
Old 04-20-2009, 04:48 PM   #2
Registered User
 
Join Date: Jan 2008
Location: Cypress, TX
Posts: 468
Quote:
Originally Posted by church27 View Post
The light comes on when I start to drive in less than a mile. I know it has a OBD 1, but is there a way to have it diagnosed, it runs great but it is annoying. thanks. Also the brake and ABS inop light is on all the time, but when I move, the low trac light flashes and i here a click with the light under the hood, any ideas on that one, thanks again.
Most auto parts stores will scan for codes, for free.
__________________
Red 95 Z28 convertible/Kooks/Yank 3200/FLT 4L60E/K&N CAI/MSD/Meziere
Red 95 Z28 T-Top/T56/Kooks /// '86 Porsche 944 Turbo
Canary yellow 64 Buick LaSabre convertible
Grey/black 99 Suzuki Hayabusa, 205 HP
caldercay is offline   Reply With Quote
Old 04-20-2009, 06:33 PM   #3
Registered User
 
Join Date: Nov 1998
Location: Louisville, KY
Posts: 2,638
Most auto parts stores are unable to pull codes from a '95, because of it being OBDI with the OBDII port. You'll have to find a friend with the proper code reader/scan tool, or go to a garage. As far as the brake/ABS light, that will entail a trip to a garage anyway.
__________________
Artificial intelligence is no match for natural born stupidity.
moparman is offline   Reply With Quote
Old 04-20-2009, 06:33 PM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:01 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.