94 lt1 coolant leak - CamaroZ28.Com Message Board

Go Back   CamaroZ28.Com Message Board > 1967-2002 Powertrain Discussion > LT1 Based Engine Tech

Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread
Old 12-19-2005, 09:18 AM   #1
Registered User
 
z28rp's Avatar
 
Join Date: Dec 2005
Location: chicago (oak lawn)
Posts: 59
94 lt1 coolant leak

i was driving my z28 and after i stopped and took off agian, the engine started making a clicking sound and the car would move but not fast at all, when i hit the gas it wouldn't roaor and take off. when i got home i found a 3 inch hose that was broken and leaking coolant. could that broken hose be causeing the clicking and causing the car to go slow?
z28rp is offline   Reply With Quote
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant Disappearing? calaban LT1 Based Engine Tech 12 01-25-2015 10:42 AM
water/coolant leaking through this hose 94Z28LS1toLT1 LT1 Based Engine Tech 7 01-15-2015 07:18 PM
Coolant leak issues pologreen97z LT1 Based Engine Tech 2 11-08-2014 10:25 PM
LT1 stuff for sale Hot Rod Hawk Midwest 4 08-30-2002 10:12 PM
vortech heads questions revisited dansam Midwest 8 07-20-2002 01:10 PM


All times are GMT -5. The time now is 12:50 AM.

 

Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.