Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > 1967-2002 Powertrain Discussion > LS1 Based Engine Tech
Sign in using an external account
Register Forgot Password?


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 07-23-2014, 12:48 PM   #1
Registered User
 
Join Date: Jul 2014
Posts: 2
Low Engine Coolant Light

Hello Everyone,

I have a 99 z28 and the low engine coolant light has been coming on and off for about the last year. I've replaced the sensor 3 times and I am still having the same issue. Also have issues with the alarm going off when turned on as well. Not sure if it is all related. Any ideas besides unplugging it?


Thank you in advance for any suggestions
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
nathan99 is offline   Reply With Quote
Old 07-23-2014, 03:59 PM   #2
Registered User
 
Join Date: Nov 1998
Location: Macon, GA
Posts: 550
Re: Low Engine Coolant Light

Quote:
Originally Posted by nathan99 View Post
Any ideas besides unplugging it?
Nope...

Common issue and as you can see, changing the sensor only fixes the light for a short while. The later F-Bodies eliminated the coolant level sensor anyway, so if GM thought it was silly, I guess I do to. After chasing the problem myself, I just unplugged mine and check the coolant level from time to time...
__________________
'98 Camaro Z28: LS6 Longblock and much more...

-View:
www.banddirector.cz28.com
BandDirector Blk98ZM6 is offline   Reply With Quote
Old 07-23-2014, 05:27 PM   #3
Registered User
 
Join Date: Jul 2014
Posts: 2
Re: Low Engine Coolant Light

Thanks, probably going to do the same.
nathan99 is offline   Reply With Quote
Old 07-23-2014, 05:27 PM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:28 AM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.