Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > 1967-2002 Powertrain Discussion > LS1 Based Engine Tech
Sign in using an external account
Register Forgot Password?


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 06-19-2013, 11:30 PM   #1
Registered User
 
Join Date: Dec 2002
Posts: 231
Smile Clutch Problem??

Ok guy's after a launch or two going through the gears 1-4 to about quarter mile distance I am having a seriously hard time getting the pedal back from the clutch and when I do it still takes time to re-engage the gears. It seems like it needs time to "cool" but is scaring the **** out of me and won't take on street rods with anyone else in car. Is it the clutch, flywheel, syncros in the tranny?? I need and answer fast cuz its summer time and I got to go!!! lol BTW, any diagnosis or fix is appreciated and please give suggestions on parts or manufacturers used. I do want to add some h.p. at some point but this comes first. Thanks a bunch
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
__________________
go fast or go home
------------------------------------------------
02 Z28 vert black, M6, Corsa CB, Direct-flo airlid, K&N filter, Granatelli 85mm MAF, Dyno tuned, SSRA, Qwik Stick, Smooth Bellow, TB bypass, STB, C&C heads and cam, PPC LT headers, ORY-pipes !CATS, rear trailing arms, panhard bar, relocation brakcets, torque control arm, SFC's, LCA's, KYB AGX shocks and struts, Eibach anti-roll kit, 90mm throttle body, 275/17/40's, Custom Fikse rims. (430rwhp, 390rwtq)
gearslammer is offline   Reply With Quote
Old 06-25-2013, 10:14 PM   #2
Registered User
 
Join Date: Dec 2002
Posts: 231
Re: Clutch Problem??

Nobody? Really?
__________________
go fast or go home
------------------------------------------------
02 Z28 vert black, M6, Corsa CB, Direct-flo airlid, K&N filter, Granatelli 85mm MAF, Dyno tuned, SSRA, Qwik Stick, Smooth Bellow, TB bypass, STB, C&C heads and cam, PPC LT headers, ORY-pipes !CATS, rear trailing arms, panhard bar, relocation brakcets, torque control arm, SFC's, LCA's, KYB AGX shocks and struts, Eibach anti-roll kit, 90mm throttle body, 275/17/40's, Custom Fikse rims. (430rwhp, 390rwtq)
gearslammer is offline   Reply With Quote
Old 06-25-2013, 10:14 PM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:24 PM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.