Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > 1967-2002 Powertrain Discussion > LS1 Based Engine Tech
Sign in using an external account
Register Forgot Password?
Register Garage Photos Blogs FAQ Members List Social Groups Links Calendar Search Today's Posts Mark Forums Read Z28LiveVendor Directory


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 06-09-2013, 05:00 PM   #1
Registered User
 
Join Date: Jun 2013
Posts: 1
Cool 2001 camaro v8 help po300 code

I need help please I have tried everything car idles rough and has a slight backfiring sound while idling when driving seems to run fine after you get over 40 mph but stopped at lights or just sitting is horrible whole car shakes everything in the car is stock no aftermarket upgrades just changed all the spark plugs and wires had its scanned said it was a po300 then scanned again and it was a po306 so I checked the #6 cylinder and changed the coil and still runs horrible all the o2 sensors are reading fine changed all of them within the last year and the mass airflow sensor also nobody seems to know what would be causing this been in the shop over and over I am tired of chasing codes at this point if any one has had this problem or knows what it might be it would be awesome. Thanks for Your help!
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
bggordo13 is offline   Reply With Quote
Old 06-10-2013, 02:20 PM   #2
Registered User
 
WhiteHawk's Avatar
 
Join Date: Feb 2004
Posts: 942
Re: 2001 camaro v8 help po300 code

Who are you taking it to? Was it a dealer? You might have an electrical gremlin in there and they have a machine that can piinpoint it at the dealer. If it was a dealer, i would ask for a refund if they charged you and couldn't figure it out.

I have seen a cracked spark plug cause that before. If it wasn't doing that before you changed them I would check them all.

-Geoff
__________________
11 Silverado - No times yet.
99Z28 - 11.91@118.5. 403 L76/L92 with street tires and launching with the traction control.
WhiteHawk is offline   Reply With Quote
Old 06-10-2013, 02:20 PM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:10 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.