Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > 1967-2002 F-Body Technical Discussion > General 1967-2002 F-Body Tech
Sign in using an external account
Register Forgot Password?
Register Garage Photos Blogs FAQ Members List Social Groups Links Calendar Search Today's Posts Mark Forums Read Z28LiveVendor Directory


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 06-17-2013, 03:23 PM   #1
Registered User
 
Join Date: Jun 2013
Location: Madison Wisconsin
Posts: 44
Low coolant????

my 94 Z low coolant light keeps coming on but i had it checked out and the coolant is within the marks, car runs hot, stays real close to the red line. anyone know whats going on here??
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
__________________
1994 Z28 74,847 miles Auto BBK headers, 3 inch American Thunder exhaust, K&N cold air intake, 4.10 gears, Hypertech Power Programmer, 160 thermostat, 02 corvette rims 18 back 17 front, some suspension upgrades but im not exactly sure what the guy i bought it from did
TaskForce141 is offline   Reply With Quote
Old 06-17-2013, 03:32 PM   #2
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 41,156
Garage
Re: Low coolant????

Sounds like you are checking the level in the coolant reservoir ("between the marks"). You have to check the coolant level in the radiator, since the level sensor in on the passenger side radiator end tank, engine side, a couple inches below the fill cap.

The level in the radiator has to be right up to the very top. Any air in the system will reduce the system cooling capacity.

If you find the radiator is full, and the "low coolant" light is still on, the level sensor is a common failure part. The coolant seeps into the printed circuit board and corrodes it. The sensor can be replaced, or you can unplug the harness, which will turn the dash light out.
__________________
Fred

94 Formula A3+1: 381ci all-forged stroker - Callies Stealth, Oliver 5.85 billet rods, BME nitrous pistons / CNC LT4 heads / Comp Cams custom solid roller / TH400 + GearVendors OD / Strange 12-bolt - 4.11's / 300-shot N2O / Spohn suspension / 6-pt roll bar with integrated SFC's / AutoMeter instrumentation / MoTeC M48Pro engine management system / a few other odds 'n ends. 800HP/800LB-FT at the flywheel.
Injuneer is offline   Reply With Quote
Old 06-17-2013, 04:24 PM   #3
Registered User
 
Join Date: Jun 2013
Location: Madison Wisconsin
Posts: 44
Re: Low coolant????

Thanks man im going to check now, your awesome. i love this site, glad i found it.
__________________
1994 Z28 74,847 miles Auto BBK headers, 3 inch American Thunder exhaust, K&N cold air intake, 4.10 gears, Hypertech Power Programmer, 160 thermostat, 02 corvette rims 18 back 17 front, some suspension upgrades but im not exactly sure what the guy i bought it from did
TaskForce141 is offline   Reply With Quote
Old 06-17-2013, 04:38 PM   #4
Registered User
 
Join Date: Jun 2013
Location: Madison Wisconsin
Posts: 44
Re: Low coolant????

so i checked it and the fluid is still to the top, so will it hurt to keep driving it with the low coolant light still coming on until i can replace the sensor? i dunno where the wire is to unhook it. im very green when it comes to tinkering under the hood my friend.
__________________
1994 Z28 74,847 miles Auto BBK headers, 3 inch American Thunder exhaust, K&N cold air intake, 4.10 gears, Hypertech Power Programmer, 160 thermostat, 02 corvette rims 18 back 17 front, some suspension upgrades but im not exactly sure what the guy i bought it from did
TaskForce141 is offline   Reply With Quote
Old 06-17-2013, 06:26 PM   #5
Registered User
 
Join Date: Nov 1998
Location: Louisville, KY
Posts: 2,638
Re: Low coolant????

No, it won't hurt it. The sensor is by the battery, on the side of the radiator.
__________________
Artificial intelligence is no match for natural born stupidity.
moparman is offline   Reply With Quote
Old 06-17-2013, 07:12 PM   #6
Registered User
 
Join Date: Jun 2013
Location: Madison Wisconsin
Posts: 44
Re: Low coolant????

Right on thanks guys. I gotta another question concerning my thermostat. First I dont know where its located, I just wanna check it out to see if its an aftermarket 160 degree thermostat. When I find it how would i know ? When I got the car the programmer chip was set on a 160 and Im just wanting to verify that.
__________________
1994 Z28 74,847 miles Auto BBK headers, 3 inch American Thunder exhaust, K&N cold air intake, 4.10 gears, Hypertech Power Programmer, 160 thermostat, 02 corvette rims 18 back 17 front, some suspension upgrades but im not exactly sure what the guy i bought it from did
TaskForce141 is offline   Reply With Quote
Old 06-17-2013, 08:35 PM   #7
Registered User
 
Join Date: Nov 1998
Location: Louisville, KY
Posts: 2,638
Re: Low coolant????

You need to bookmark this site: 4th Gen LT1 F-Body Tech Aids

It's one of the sites you'll use. Shoebox has the lowdown on thermostats on that site.
__________________
Artificial intelligence is no match for natural born stupidity.
moparman is offline   Reply With Quote
Old 06-17-2013, 10:01 PM   #8
Registered User
 
Join Date: Jun 2013
Location: Madison Wisconsin
Posts: 44
Re: Low coolant????

moparman 2 seconds on that site you mentioned and i found where my thermostat is located. lol. thanks man. i will def bookmark that site so i can refer to it later because i know im gonna find something else to be hung up on. thermostat doesnt look too complicated too check on now as it did before.
__________________
1994 Z28 74,847 miles Auto BBK headers, 3 inch American Thunder exhaust, K&N cold air intake, 4.10 gears, Hypertech Power Programmer, 160 thermostat, 02 corvette rims 18 back 17 front, some suspension upgrades but im not exactly sure what the guy i bought it from did
TaskForce141 is offline   Reply With Quote
Old 06-18-2013, 06:42 AM   #9
Registered User
 
Join Date: Nov 1998
Location: Louisville, KY
Posts: 2,638
Re: Low coolant????

Take notice that the LT1 has it's own specific thermostat. The standard small block Chevy 'stat does not perform properly in the LT1.
__________________
Artificial intelligence is no match for natural born stupidity.
moparman is offline   Reply With Quote
Old 06-18-2013, 06:42 AM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:32 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.