Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > 1967-2002 F-Body Technical Discussion > General 1967-2002 F-Body Tech
Sign in using an external account
Register Forgot Password?


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 09-01-2013, 10:00 AM   #1
Registered User
 
Join Date: Aug 2013
Posts: 14
a little warning to those who go the new all LED craze

since the previous owner put all led's in the car, I mean every light inside and out is LED's besides the headlights of course, he even did the cluster lighting,

I had lights that would show up then not show up for ABSinOP, Brake and other lights, well I took the cluster out and changed them back to normal bulbs, all the lights are now off, I chased the abs crap for 2 weeks ready to buy a module and sensors when all along it was the led's being so bright they bled thru.

I'm in the process of even going back to stock tail lights, I really don't like the LED's..
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
IndianScout is offline   Reply With Quote
Old 09-01-2013, 04:43 PM   #2
Registered User
Premium Member
 
GaryDoug's Avatar
 
Join Date: Jul 2010
Location: Florida West Coast
Posts: 417
Garage
Re: a little warning to those who go the new all LED craze

The newer high-intensity LEDs take very little current to light up. They really need a much larger current-limiting resistor to work correctly.
__________________
1998 Trans Am, LS1, Automatic, stock all the way.
GaryDoug is offline   Reply With Quote
Old 09-01-2013, 04:43 PM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:25 AM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.