CamaroZ28.Com Message Board

CamaroZ28.Com Message Board (http://www.camaroz28.com/forums/)
-   General 1967-2002 F-Body Tech (http://www.camaroz28.com/forums/general-1967-2002-f-body-tech-46/)
-   -   97 Z28 issues, any help would be appreciated (http://www.camaroz28.com/forums/general-1967-2002-f-body-tech-46/97-z28-issues-any-help-would-appreciated-876616/)

Noct 11-01-2013 12:01 PM

97 Z28 issues, any help would be appreciated
 
Hey guys, couple of issues I'm facing that I'm not sure what to do about...
97 Z28 Lt1, (auto-trans), has 118k on it. I've only had it for a few months, and I love it more then my wife.

FYI, I'm not extremely gear-savvy, but I've had about 10 Camaros at this point, and I've done a lot of work on them myself over the years. Mostly minor stuff, alternators, starters, heater cores, etc... I don't know very much, but I can typically get by with my Chilton manual and some solid info from experts.

Ok, so when I tried to start my car this morning, it wouldn't turn over. It was raining pretty heavy, and had been all night, and this is the first time this has happened, so I have to assume it's related.

Starter was working fine, just wouldn't turn over. Kept getting almost over, then kinda sounded like it was choking out, would sputter a bit, and then go silent. After trying it repeatedly for about 5 minutes, it eventually turned, and then drove just fine. Drove it for about an hour after, turned it on and off repeatedly, no problems.

I would assume this was some electrical component that got too wet ya? Where would I start with diagnosing this? I was going to just change all the plugs and wires this weekend, but I haven't done that on this car yet, and from what I hear, it's a nightmare on this model. Is that true? Also, I hear that this could be the optispark, and that is not only expense, but probably not something I should attempt myself? Again, any truth to that?

Not sure if this is related or not, but I've been experiencing some general poor performance lately with it. Doesn't have the power it should, sputters or does a very light backfire when I'm going over 55 and take my foot off the accelerator... These things could all be pointing to an issue with firing yeah?

Any help you guys could give me would be greatly appreciated.

moparman 11-01-2013 12:16 PM

Re: 97 Z28 issues, any help would be appreciated
 
First thing is to get it scanned for trouble codes.

parkers Z28 11-01-2013 05:04 PM

Re: 97 Z28 issues, any help would be appreciated
 
check for codes ..
I changed the plugs & wires in my car about 5 weeks ago Yes it was a pain in the a**
but not impossible 4-5 hours... Don't go any larger than 8mm plug wires !! if you get to that point

Injuneer 11-01-2013 05:45 PM

Re: 97 Z28 issues, any help would be appreciated
 
The high humidity may have dampened the plug wires or the Optispark distributor. Particularly if you had a sudden temp increase, where the high moisture content in the saturated warm air started to condense out on a cold engine. The Opti is particularly sensitive to water, and may already have had a problem, causing the low power, sputtering, etc.

As noted, scan it for codes. If the problem with the Opti is the optical cam position sensor, it will set two possible codes. If the problem is wet cap/wires, affecting the high voltage section, it won't set codes unless it runs enough for the PCM to pick up the misfires. But it appears it ran for a while, so pull the codes and look for P0300 and P0301 thru P0308 indicating misfires. If the scanner had "GM Enhanced Parameter" capabilites, you can actually pull the misfire count by individual cylinder, which will tell you if it's a truely random misfire, or specific to one or more cylinders.

If you have a problem that sets one or both of the codes for the cam position sensor (P0372 - high resolution; P1371 - low resolution) check both ends of the short harness that leads from the gray connector on the bracket on the passenger side of the intake manifold to the distributor. It isn't uncommon for the pins to grow a strange blue corrosion, particularly on the end that plugs into the distributor.

Also check the plug wires and coil wire for dampness, and check the plug and coil wire terminals in the distributor for corrosion and/or dampness.


All times are GMT -5. The time now is 10:08 AM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.