Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > 1967-2002 F-Body Technical Discussion > General 1967-2002 F-Body Tech
Sign in using an external account
Register Forgot Password?
Register Garage Photos Blogs FAQ Members List Social Groups Links Calendar Search Today's Posts Mark Forums Read Z28LiveVendor Directory


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 06-30-2013, 03:01 AM   #1
Registered User
 
Join Date: Jun 2013
Location: jacksonville fla.
Posts: 13
94 lt1 383 running rich loseing power when warm

Hey new to site car act really funny throttle response is good cold get worse warm And i get real loud backfire when i rev eng on decel and u can smell gas bad to tell little more bout car it has long tube headers 180cc afr heads hotcam eagle crank been tuned by pcmforless if anyone can help thanks
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
jmarkum is offline   Reply With Quote
Old 06-30-2013, 09:44 AM   #2
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 40,764
Garage
Re: 94 lt1 383 running rich loseing power when warm

How old are the O2 sensors? Any sign of misfires? That will cause the engine to run rich based on the feedback from the O2 sensors? So will exhaust leaks before the O2 sensors.
__________________
Fred

94 Formula A3+1: 381ci all-forged stroker - Callies Stealth, Oliver 5.85 billet rods, BME nitrous pistons / CNC LT4 heads / Comp Cams custom solid roller / TH400 + GearVendors OD / Strange 12-bolt - 4.11's / 300-shot N2O / Spohn suspension / 6-pt roll bar with integrated SFC's / AutoMeter instrumentation / MoTeC M48Pro engine management system / a few other odds 'n ends. 800HP/800LB-FT at the flywheel.
Injuneer is offline   Reply With Quote
Old 06-30-2013, 03:12 PM   #3
Registered User
 
Join Date: Jun 2013
Location: jacksonville fla.
Posts: 13
Re: 94 lt1 383 running rich loseing power when warm

No exhaust leaks and new denso o2 sensors so gonna try to data log again and opti is new so im lost right now till i data log thanks for ur reply
jmarkum is offline   Reply With Quote
Old 07-01-2013, 10:57 AM   #4
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 40,764
Garage
Re: 94 lt1 383 running rich loseing power when warm

Did you have the problem BEFORE you installed the new Denso O2 sensors? Most people report the best results with AC Delco or Delphi sensors.
__________________
Fred

94 Formula A3+1: 381ci all-forged stroker - Callies Stealth, Oliver 5.85 billet rods, BME nitrous pistons / CNC LT4 heads / Comp Cams custom solid roller / TH400 + GearVendors OD / Strange 12-bolt - 4.11's / 300-shot N2O / Spohn suspension / 6-pt roll bar with integrated SFC's / AutoMeter instrumentation / MoTeC M48Pro engine management system / a few other odds 'n ends. 800HP/800LB-FT at the flywheel.
Injuneer is offline   Reply With Quote
Old 07-01-2013, 01:40 PM   #5
Registered User
 
Join Date: Jun 2013
Location: jacksonville fla.
Posts: 13
Re: 94 lt1 383 running rich loseing power when warm

No i bought car it had 93 ecm so i switched over to 94 pcm and 94 intake i bought the heated denso 02 sensors never tryed anything else the other sensors was one wire i think they where bosch which i no r bad but i can give ac delco a try ill try anything a this point thanks for ur reply keep them coming cause car geting like 8 mpg it sucks had pcm tuned for accel 30lb injectors maybe the guy lie to me bought what wad in motor he said it was 383 but no way to tell unless i pull oil pan and look at crank dont really no if its the tune r what might just fork out money and get a dyno tune here in jax fl. By HP TUNERS GUY NAME IS TONY GUNONER THINK I SPELLED THAT RIGHT
jmarkum is offline   Reply With Quote
Old 07-01-2013, 01:48 PM   #6
Registered User
 
Join Date: Jun 2013
Location: jacksonville fla.
Posts: 13
Re: 94 lt1 383 running rich loseing power when warm

Guy i bought car from seem like good guy and showed me all paper work of what was done to car but these days u cant trust no one and mailorder tunes arent that great from what i here i gues i find out when i do a rebuild and tear motor down i might just do that that way i no everything is right with motor
jmarkum is offline   Reply With Quote
Old 07-01-2013, 02:07 PM   #7
Registered User
 
Join Date: Jun 2013
Location: jacksonville fla.
Posts: 13
Re: 94 lt1 383 running rich loseing power when warm

Dam fred i just looked at ur car now thats a car bad *** u must love it u got to have a passion for race looks like alot of $$$$ in that car my last camaro ran 12.03 at 109 mph i thoght that was fast for all motor i bet ur runing low 10s beautiful car man ill get mine there one day hopefully
jmarkum is offline   Reply With Quote
Old 07-01-2013, 02:07 PM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:03 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.