CamaroZ28.Com Message Board

CamaroZ28.Com Message Board (http://www.camaroz28.com/forums/)
-   General 1967-2002 F-Body Tech (http://www.camaroz28.com/forums/general-1967-2002-f-body-tech-46/)
-   -   93 camaro z28 Problem with speedometer!!!! (http://www.camaroz28.com/forums/general-1967-2002-f-body-tech-46/93-camaro-z28-problem-speedometer-876757/)

alienman86 11-11-2013 04:15 PM

93 camaro z28 Problem with speedometer!!!!
 
I have a problem with my speedo. when the car is idling its find it sits at 0 then you rev the motor it moves and when you put it in gear the speedo goes to 150mph? please help thank to anyone that can help i can take a video too if anyone needs one.:think:

alienman86 11-11-2013 06:07 PM

Re: 93 camaro z28 Problem with speedometer!!!!
 
Its a 1993 camaro z28 a/t lt4 with some mods.

alienman86 11-11-2013 08:20 PM

Re: 93 camaro z28 Problem with speedometer!!!!
 
can it be the computer going bad?

Injuneer 11-12-2013 07:31 AM

Re: 93 camaro z28 Problem with speedometer!!!!
 
The 93 factory manual is contradictory with regard to the speedometer operation. In one place it describes a "VSS buffer" located in the under hood convenience center. The buffer is the device that converts the VSS output to the signal required by the speedometer. If that is correct, 1993 would be the only year that uses this configuration. Later years feed the VSS signal to the PCM, and the PCM drives the speedometer. 93 is different in many respects, with the tachometer driven directly off the coil, via a filter, where other years drive the tach from the PCM.

Yet elsewhere in the factory manual, the wiring diagrams show the VSS signal splitting and feeding both the ECM and the speedometer/odometer section of the cluster, and do not show a buffer.

Look in the under hood fuse/relay box to see if there is any indication of the VSS buffer.

Could be the VSS, could be the buffer (if it exists), could be the speedometer or could be high voltage interference on the VSS signal wires.

alienman86 04-08-2014 11:12 PM

Re: 93 camaro z28 Problem with speedometer!!!!
 
Ok there is no speed buffer I will put a video up with a link to youtube

alienman86 04-08-2014 11:35 PM

Re: 93 camaro z28 Problem with speedometer!!!!
 
ok here is the link for youtube guy let me know what you think,

Z28barnett 05-29-2014 08:02 PM

Re: 93 camaro z28 Problem with speedometer!!!!
 
I have a version of this problem.

Started the car to day with the wheels chocked and parking brake on.

When I rev the engine to 3000 rpm the speedo goes to 10mph with the car sitting still.

1995 Z28 lt1 6 spd.

Anybody fixed a problem like this? ECM bad?


All times are GMT -5. The time now is 12:34 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.