Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > 1967-2002 F-Body Technical Discussion > General 1967-2002 F-Body Tech
Sign in using an external account
Register Forgot Password?


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 04-19-2012, 03:38 PM   #1
Registered User
 
Join Date: Jan 2012
Posts: 15
1995 camaro loss of power and delayed shifting

I got a 95 z28 i just recently changed out the map sensor on my car but after i changed it the engine started making a horrible whistling sound and lost a bunch of power i have trouble just going up hills. Also when im driving very slowly its changing gears fine but when i give it more gas and it hits about 3000 rpms its not wanting to change gears till i let off the gas i dont know whats going on i've had all my vacuum lines checked, my exhaust checked to see if it was stopped up and my fuel pressure checked to make sure my fuel pump is working properly i've also had my transmission checked but all of that was good i dont know what else to check could anybody help me please.
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
wpreston1990 is offline   Reply With Quote
Old 04-19-2012, 05:04 PM   #2
Registered User
 
mrmint69's Avatar
 
Join Date: Oct 2006
Location: Post Falls, Idaho
Posts: 2,653
Re: 1995 camaro loss of power and delayed shifting

Have you tried putting the old part back to see if that changes things? Did it start the second you drove with the new part or was it a while after?
__________________
1994 Z-28 LT1 A4, Supercharger 6 psi, 3.73 Gears, GMPP 1.6 Rockers, LT4 Springs, 42LB Bosch injectors, PCMFORLESS tune, All MSD ignition, Inline fuel pump, SLP sub frames, Panhard Bar, strut bar and rear control arms & LCA relocation, 1LE sway bar, Mid pacesetter's. 3" exhaust to Jegs electric cutout. Nitto NT555R Extreme Drag Radial 275/40R17
mrmint69 is offline   Reply With Quote
Old 04-19-2012, 06:43 PM   #3
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 41,284
Garage
Re: 1995 camaro loss of power and delayed shifting

Did you install the rubber seal on the MAP sensor?
__________________
Fred

94 Formula A3+1: 381ci all-forged stroker - Callies Stealth, Oliver 5.85 billet rods, BME nitrous pistons / CNC LT4 heads / Comp Cams custom solid roller / TH400 + GearVendors OD / Strange 12-bolt - 4.11's / 300-shot N2O / Spohn suspension / 6-pt roll bar with integrated SFC's / AutoMeter instrumentation / MoTeC M48Pro engine management system / a few other odds 'n ends. 800HP/800LB-FT at the flywheel.
Injuneer is offline   Reply With Quote
Old 04-19-2012, 06:44 PM   #4
Registered User
 
Join Date: Jan 2012
Posts: 15
Re: 1995 camaro loss of power and delayed shifting

it started with the old part on there but not as bad as now after i put the new one on i dont have the old part
wpreston1990 is offline   Reply With Quote
Old 04-19-2012, 06:46 PM   #5
Registered User
 
Join Date: Jan 2012
Posts: 15
Re: 1995 camaro loss of power and delayed shifting

it didnt come with the seal so i used my old seal till i got the new one from the chevy place
wpreston1990 is offline   Reply With Quote
Old 04-19-2012, 06:46 PM
 
Reply Post New Thread

Tags
delayed shift, lt1 map sensor, power loss

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:17 AM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.