1995 camaro loss of power and delayed shifting - CamaroZ28.Com Message Board


Reply
 
LinkBack Thread Tools Search this Thread
Old 04-19-2012, 04:38 PM   #1
Registered User
Thread Starter
 
Join Date: Jan 2012
Posts: 15
1995 camaro loss of power and delayed shifting

I got a 95 z28 i just recently changed out the map sensor on my car but after i changed it the engine started making a horrible whistling sound and lost a bunch of power i have trouble just going up hills. Also when im driving very slowly its changing gears fine but when i give it more gas and it hits about 3000 rpms its not wanting to change gears till i let off the gas i dont know whats going on i've had all my vacuum lines checked, my exhaust checked to see if it was stopped up and my fuel pressure checked to make sure my fuel pump is working properly i've also had my transmission checked but all of that was good i dont know what else to check could anybody help me please.
wpreston1990 is offline   Reply With Quote
Old 04-19-2012, 06:04 PM   #2
Registered User
 
mrmint69's Avatar
 
Join Date: Oct 2006
Location: Post Falls, Idaho
Posts: 2,653
Re: 1995 camaro loss of power and delayed shifting

Have you tried putting the old part back to see if that changes things? Did it start the second you drove with the new part or was it a while after?
mrmint69 is offline   Reply With Quote
Old 04-19-2012, 07:43 PM   #3
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 44,953
Re: 1995 camaro loss of power and delayed shifting

Did you install the rubber seal on the MAP sensor?
Injuneer is offline   Reply With Quote
Old 04-19-2012, 07:44 PM   #4
Registered User
Thread Starter
 
Join Date: Jan 2012
Posts: 15
Re: 1995 camaro loss of power and delayed shifting

it started with the old part on there but not as bad as now after i put the new one on i dont have the old part
wpreston1990 is offline   Reply With Quote
Old 04-19-2012, 07:46 PM   #5
Registered User
Thread Starter
 
Join Date: Jan 2012
Posts: 15
Re: 1995 camaro loss of power and delayed shifting

it didnt come with the seal so i used my old seal till i got the new one from the chevy place
wpreston1990 is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Coolant Disappearing? calaban LT1 Based Engine Tech 15 09-04-2016 04:11 PM
LT1 engine swap help needed. 1996 z28 motor/trans into 1995 z28 dbusch22 LT1 Based Engine Tech 2 01-05-2015 08:14 PM
1995 Triple Black Z28 Convertible for sale. joe777107 Cars For Sale 1 12-01-2014 10:32 AM
TA steering wheel controls for stereo SLIMJIM Car Audio and Electronics 8 01-07-2003 12:06 PM
Silly questions, but an easy one for you install guys. Need help! Chrisdude Car Audio and Electronics 5 07-24-2002 03:25 PM


Tags
delayed shift, lt1 map sensor, power loss

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:07 AM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.