Go Back   CamaroZ28.Com Message Board > 1967-2002 F-Body Technical Discussion > General 1967-2002 F-Body Tech
Sign in using an external account
Register Forgot Password?


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 09-29-2013, 10:51 PM   #1
Registered User
 
Join Date: Sep 2013
Posts: 1
00 z28 A/C makes noise upon acceleration

I just recently purchased a 2000 camaro z28.

The previous owner told me the AC blew cold but made a noise when you accelerate .

My mechanic told me that the bearing was bad , so i replaced it. AC blows ice cold and works perfect. But when i accelerate it makes a whistling kind of noise when i turn the AC off the noise stops completely..

What else could it be ?

pulley ? clutch ?

thanks guys . look forward to be a contributing member to this forum .

also if this is not in the right place please direct me to where i should post these kinds of questions at.
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
polorico is offline   Reply With Quote
Old 09-29-2013, 10:51 PM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:21 AM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.