PCM/Ignition fuse - CamaroZ28.Com Message Board


Reply
 
LinkBack Thread Tools Search this Thread
Old 08-21-2011, 10:11 AM   #1
Registered User
Thread Starter
 
ppastorius's Avatar
 
Join Date: Aug 2011
Posts: 2
PCM/Ignition fuse

I have a 94 Z28, LT1, for awhile it was blowing PCM/Ignition fuse then it would just stop and car would start. I haven't driven the car any distance yet because tow bills aren't cheap, car ran in my drive way for awhile without blowing the fuse. I also have another issue now, the ses light comes on with the cooling fans and the fans will not shut off. Can someone please help me I want my car back on the street!
ppastorius is offline   Reply With Quote
Old 08-21-2011, 10:29 AM   #2
Super Moderator
 
Injuneer's Avatar
 
Join Date: Nov 1998
Location: Hell was full so they sent me to NJ
Posts: 44,965
Re: PCM/Ignition fuse

You have to look at all the devices that are connected to the "PCM IGN" fuse. One of them (or the wiring to it) has a short. According to my 94 Owner's Manual, Fuse 5 "PCM IGN" connects to the PCM, the fuel pump relay and the PASS-Key module. Check you Owner's Manual, but it should be the same for the Camaro and Firebird. If you don't have an Owner's Manual, Shoebox has a link to copies on line:

http://shbox.com/pdf/manuals.html

There are several codes that, when set, cause the PCM to run the fans full-time. You have to scan it for codes and correct the problem to turn the SES light and the fans off. The most common problem is DTC 29 for a blown fuse for the AIR pump. Check fuse 7 in the under hood box. If it's not that, get it scanned.
Injuneer is offline   Reply With Quote
Old 08-21-2011, 04:17 PM   #3
Registered User
Thread Starter
 
ppastorius's Avatar
 
Join Date: Aug 2011
Posts: 2
Re: PCM/Ignition fuse

Thanks I will check those things out, my problem is finding a obd1 scan tool...
ppastorius is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
94 Z28 Cranks but will not start Jeff1904 General 1967-2002 F-Body Tech 5 06-05-2016 06:00 PM
4th Gen wiper motor rattles- vibration autoxr166 General 1967-2002 F-Body Tech 0 09-25-2015 05:21 PM
1997 z28 Camaro cranks n cranks no start!! Ryan Ramsaran LT1 Based Engine Tech 3 09-19-2015 09:43 PM
Window and door locks both not working z28cam1993 General 1967-2002 F-Body Tech 14 09-09-2015 05:08 AM
95 T/A No start. No power to ICM. RUNMYTA Fuel and Ignition 3 07-15-2015 08:50 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:39 PM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.