cant figure out my backfire and misfire on my 97 lt1 - CamaroZ28.Com Message Board

Go Back   CamaroZ28.Com Message Board > 1967-2002 F-Body Technical Discussion > 1967-2002 Specific Technical Discussion > Fuel and Ignition

Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread
Old 08-30-2010, 02:23 PM   #1
Registered User
 
Join Date: Jul 2010
Location: millington,mi
Posts: 5
cant figure out my backfire and misfire on my 97 lt1

i have a 97 camaro lt1 sixspeed. car is misfireing and poping when hard on the accelerator. i put a brand new optispark new wires and new plugs in it and the problem did not get any better. i noticed when i rev the engine in neutral the mph gauge also goes up to 30 when car is not even moving. i checked all my grounds and i am just lost. does anyone have any suggestions at all. any ideas would be really appreciated . thank you in advance
jmkopac is offline   Reply With Quote
Old 08-31-2010, 10:15 AM   #2
Registered User
 
Join Date: Jul 2003
Location: Upstate New York
Posts: 700
Maybe try leaning it out if you have software.
My car developed a miss from being too rich.
When I leaned it out the miss went away.
__________________
97 Z28 383 M6 Vert,SS Hood,Trickflow Heads TPiS Longtubes and 2 Cat Y Pipe, Magnaflow, MSD ignition 3.73,CragarSS Classic, 4.5 psi Powerdyne.
2cub49 is offline   Reply With Quote
Old 08-31-2010, 09:47 PM   #3
Registered User
 
Join Date: Oct 1998
Location: jackson, ohio, usa
Posts: 188
On the front of the engine, driver's side on the head, is a finned aluminum mount with the ignition module on it. I'd get it tested first off. Autozone will do it free.
tom2 is offline   Reply With Quote
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trans issue PCLZ28 Drivetrain 6 03-03-2015 09:10 AM
94 Z28 issues bfmv13trivium General 1967-2002 F-Body Tech 9 01-14-2015 09:57 AM
Hello from Vegas smokin25th New Member Introduction 2 01-01-2015 09:06 AM
1994 z28 lt1 misfiring Dyoung_Z28 General 1967-2002 F-Body Tech 8 11-25-2014 05:26 PM
Help! 02 WS6 Misfire on all cylinders UT Trans AM General 1967-2002 F-Body Tech 2 11-17-2014 06:07 AM


All times are GMT -5. The time now is 01:57 PM.

 

Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.