Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > Community > F-body Lounge
Sign in using an external account
Register Forgot Password?


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 03-08-2012, 04:45 PM   #1
Registered User
 
Join Date: Aug 2006
Location: Hendersonville Tn.
Posts: 215
Car won't crank-security light on.

95 LTI Formula auto. I tried to start and no crank but the security light was on, i have never seen it on before. I had running bout an hour ago and no problem. What do i need to do. Danny Mc
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
Danny McAdams is offline   Reply With Quote
Old 03-08-2012, 04:46 PM   #2
Registered User
 
UnknownWarrior's Avatar
 
Join Date: Jun 2008
Location: Arlington Texas
Posts: 85
Re: Car won't crank-security light on.

Quote:
Originally Posted by Danny McAdams View Post
95 LTI Formula auto. I tried to start and no crank but the security light was on, i have never seen it on before. I had running bout an hour ago and no problem. What do i need to do. Danny Mc
problem with the VATS system, you either need a new key, do a chip bypass or need a new vats computer
__________________
2010 Summit White 2SS/RS Camaro- GMPP Exhaust, Doug Thorley LT's, SNL V.X Cam package
UnknownWarrior is offline   Reply With Quote
Old 03-08-2012, 06:17 PM   #3
Registered User
 
greenformula94's Avatar
 
Join Date: Feb 2012
Location: Minnesota
Posts: 235
Re: Car won't crank-security light on.

In order for you to drive it right now, you gotta unlock the car, get in, put the key in the ignition and sit for 5-10 minutes without touching a single button in the car.

I had this happen numerous times on a buick i had, a sunfire, and i think my firebird did it once.

it can be caused by a dirty key, bad key, or the chip is getting old.

but if you sit in there with the key forward and dont touch anything it starts right up.
__________________
1994 Pontiac Firebird Formula - Under the knife
2004 Mazda 3i - Daily beater
2000 Jeep Cheroke Sport 2dr - Backup Toy
greenformula94 is offline   Reply With Quote
Old 03-08-2012, 06:41 PM   #4
Registered User
 
jloshotz's Avatar
 
Join Date: Jan 2006
Location: Long Island N.Y. Via Powhatan VA
Posts: 649
Garage
When this happened on my previous z, it just started happening more frequently over time. VERY annoying, because it usually happens when you are running late, and it FORCES you to wait lol. I was able to get lucky...I shot some contact cleaner, and then some keyboard duster (both with a straw) in the ignition cylinder. Then I cleaned the key pellet on both sides with a pencil eraser. Worked like a champ, my problem went away. Like I said, lucky lol. Might want to give it a shot though before spending money or time attempting to bypass. Good luck.
__________________
1995 Z28 M6 Swapped, 3.73 Gears, LS brakes w/slotted rotors & Hawk pads, Pro 5.0 shifter, GMPP CAI, BBK Shorties, LT4 KM, LT4 Hotcam, Crane Race gold 1.6 rr's, 160 T-stat, Magnaflow stainless axle-back, TPiS Aluminum Driveshaft, MSD Blaster 2 and 6AL, BMR tubular LCA's, panhard, adj. TQ arm with BMR trans X-member, Hotchkis STB, UMI SFC's, 52mm Holley
jloshotz is offline   Reply With Quote
Old 03-08-2012, 06:58 PM   #5
Registered User
 
ImportKILLER's Avatar
 
Join Date: Aug 1999
Location: I'm in the Bay, Trick
Posts: 1,165
Re: Car won't crank-security light on.

Ignition cylinder.

Had to replace mine a few years ago.
__________________
"No, no puedes"
ImportKILLER is offline   Reply With Quote
Old 03-08-2012, 07:35 PM   #6
Registered User
 
94Camaro_Z_28's Avatar
 
Join Date: Feb 2005
Location: La Porte City, Iowa
Posts: 891
Send a message via ICQ to 94Camaro_Z_28 Send a message via AIM to 94Camaro_Z_28 Send a message via MSN to 94Camaro_Z_28
Re: Car won't crank-security light on.

I wipe the key on my shirt. Tada.
__________________
1994 Chevrolet Camaro Z28 - GM847 - Stock Heads - Patriot Performance Dual Springs - Madz28 Tune - Pacesetter LT - Motive 4.10's - 12.6 @ 114
94Camaro_Z_28 is offline   Reply With Quote
Old 03-08-2012, 08:02 PM   #7
Registered User
 
jloshotz's Avatar
 
Join Date: Jan 2006
Location: Long Island N.Y. Via Powhatan VA
Posts: 649
Garage
Quote:
Originally Posted by 94camaro_z_28 View Post
i wipe the key on my shirt. Tada.
lol!
__________________
1995 Z28 M6 Swapped, 3.73 Gears, LS brakes w/slotted rotors & Hawk pads, Pro 5.0 shifter, GMPP CAI, BBK Shorties, LT4 KM, LT4 Hotcam, Crane Race gold 1.6 rr's, 160 T-stat, Magnaflow stainless axle-back, TPiS Aluminum Driveshaft, MSD Blaster 2 and 6AL, BMR tubular LCA's, panhard, adj. TQ arm with BMR trans X-member, Hotchkis STB, UMI SFC's, 52mm Holley
jloshotz is offline   Reply With Quote
Old 03-08-2012, 08:40 PM   #8
Registered User
 
knta4dnu's Avatar
 
Join Date: Feb 2004
Location: Spring Hill, Florida
Posts: 134
Re: Car won't crank-security light on.

If you don't have spray contact cleaner, flatten a Q-Tip with pliers, wet it with rubbing alcohol and you can reach the contacts in the cylinder.
__________________
SOLD, but I'm still here for the beer. '97 Z28. M6 by TickShift, T-Tops, Hot Cam Kit, LS7 lifters. Ported heads, 30lb SVO injectors, Hooker Catback, Moroso CAI, AAM 4:10's, Pro5.0, Spohn STB, LCA and Track Bar, Bilstein HD's, Kennedy's dyno tune. Speed is in the behind of the beholder
knta4dnu is offline   Reply With Quote
Old 03-08-2012, 09:11 PM   #9
Registered User
 
Join Date: Aug 2006
Location: Hendersonville Tn.
Posts: 215
Re: Car won't crank-security light on.

Thanks for the advice guys. Danny Mc
Danny McAdams is offline   Reply With Quote
Old 03-09-2012, 08:27 AM   #10
Registered User
 
Join Date: Feb 2004
Location: Stroudsburg, PA
Posts: 950
Send a message via AIM to Zigroid
Re: Car won't crank-security light on.

had same problem on my old '94 formula. you could wait (like others said) or you could disconnect the negative battery terminal and touch it to the positive terminal which is basically like letting it sit for a while without the battery connected. everything is reset.

another awkward thing is is that I had VATS disabled and also had a remote start on the car. it would start all the time with the remote start but as soon as I went to use the key I would get the damned security light and it wouldnt turn over. now im wondering if, based on the other responses in this thread, it was the key.
__________________
1999 Firebird Formula - 6 speed, 165k+ miles. bone stock dyno = 304/328, dyno graph dyno video, now with LS6 intake, ported TB, SLP lid, and 4.10s.
1991 Beretta GT - 3.1L A3, underpowered daily beaten driver
1968 Pontiac Bonneville - 400 poncho, th400 - 200 rwhp / 300 rwtq, 62k miles! For sale
Zigroid is offline   Reply With Quote
Old 03-09-2012, 09:35 AM   #11
Registered User
 
greenformula94's Avatar
 
Join Date: Feb 2012
Location: Minnesota
Posts: 235
Re: Car won't crank-security light on.

You can get them made at your local hardware store and specify you want no chip.

they wont have the gm head logo tho
__________________
1994 Pontiac Firebird Formula - Under the knife
2004 Mazda 3i - Daily beater
2000 Jeep Cheroke Sport 2dr - Backup Toy
greenformula94 is offline   Reply With Quote
Old 03-10-2012, 07:54 PM   #12
Registered User
 
Red89GTA's Avatar
 
Join Date: Apr 2002
Location: Walled Lake, MI, USA
Posts: 587
Send a message via AIM to Red89GTA
Re: Car won't crank-security light on.

Uh, oh. sounds expensive, you should go to the dealer.


or did you get it fixed already?
__________________
Steve - '89 GTA Ls1/T56 /// '05 WRX Wagon 2.0 turbo/5-speed
Red89GTA is offline   Reply With Quote
Old 03-11-2012, 11:38 AM   #13
Registered User
 
Malice 1's Avatar
 
Join Date: Jul 2005
Location: Cherry point NC
Posts: 448
Re: Car won't crank-security light on.

Whenever my 99 camaro used to do this, I would just unhook the battery and hook it back up. It took less than 5 minutes, and it started up every time after that.

It didn't do it to me to often though..
__________________
2010 CAMARO RS/SS M6 GMPP catback
Malice 1 is offline   Reply With Quote
Old 03-11-2012, 11:38 AM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:54 PM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.