Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > 1967-2002 F-Body Technical Discussion > 1967-2002 Specific Technical Discussion > Computer Diagnostics and Tuning
Sign in using an external account
Register Forgot Password?


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 04-28-2012, 11:22 PM   #1
Registered User
 
Join Date: Apr 2012
Posts: 1
94 Z28 high idle

I am having trouble with high idle concerns, it's at a shop, they think it's the lack of smog pump causing the high idle, I think not, could be wrong, also when you unplug the map sensor it doesn't effect the idle at all.....any help would be appreciated....don't know much bout the car, got it cheap, replaced,optispark,waterpump, coil, and thermostat..
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
gregory55fan is offline   Reply With Quote
Old 05-01-2012, 10:56 AM   #2
Registered User
 
Join Date: Nov 2007
Posts: 905
Re: 94 Z28 high idle

Removing Air Pump and pipes correctly (plugging manifold ports and snorkel port) will not cause high idle. High idle can be caused by Vacuum leak, TB linkage sticking, TB set screw maladjusted (blades opened to much), Coolant Temp sensor defective or incorrect tune (desired idle speed setting). Are the fans running constantly ? High how is your idle ?
__________________
I'm Bob.. 1994 Z28, A4, Stall, CAI, Cam, RR's, 342 rear, LT's , CatBack, Tuned

Last edited by bobdec; 05-01-2012 at 11:00 AM.
bobdec is offline   Reply With Quote
Old 05-01-2012, 10:56 AM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:34 AM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.