Welcome to Camaro Z28!

Welcome to CamaroZ28.Com, the ultimate Source for Camaro enthusiasts! Here you can join over 90,000 Camaro enthusiasts from around the world discussing all things related to Camaros and more. You are currently viewing as a guest which gives you limited access to view discussions

To gain full access to our forums you must register for a free account. As a registered member you will be able to:
  • Participate in over 40 different forums and search/browse from over 5 million posts.
  • Upload your Camaro details to your Garage
  • Post photos, respond to polls and access other special features
  • Gain access to our free marketplace to buy, sell and trade Camaros, parts and more.
All this and much more is available to you absolutely free when you register for an account, so join our community today today!

If you have any problems with the registration process or your account login, please contact support.


Go Back   CamaroZ28.Com Message Board > 1967-2002 Powertrain Discussion > 3rd Gen / L98 Engine Tech
Sign in using an external account
Register Forgot Password?
Register Garage Photos Blogs FAQ Members List Social Groups Links Calendar Search Today's Posts Mark Forums Read Z28LiveVendor Directory


Reply Post New Thread
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 04-26-2011, 12:06 AM   #1
Registered User
 
sabresfan's Avatar
 
Join Date: Apr 2011
Location: Rochester, NY
Posts: 210
Garage
Question Windshield Wiper Problem??

I just picked up my 1986 IROC-Z28 Camaro and I'm very excited but it needs a little tlc. I have a lot of pics posted in my first post under new member introduction.

One thing wrong with it is the windshield wipers. It works on the low setting but it does not work on high. When I flip it to the high setting the wipers freeze and don't move. And then my dad told me they wont shut off (I'm away at college right now and he's messing with it a little). I feel like it just needs a new wiper motor but I'm not sure.

Any suggestions??
This ad is not displayed to registered members.
Register your free account today and become a member on CamaroZ28.com!
sabresfan is offline   Reply With Quote
Old 05-03-2011, 09:46 PM   #2
Registered User
 
Join Date: Nov 1999
Location: Pittsburgh, PA
Posts: 43
Garage
Re: Windshield Wiper Problem??

I've got a similar problem. When I turn on the wipers to intermittent nothing happens. Regular speed wipers move to the bottom of the windshield. Fast speed, wipers stay at the bottom of the window then jerk up and down moving a half inch or so. After cycling through a few times, they start working again but only at the fastest setting. Any ideas if it is a motor or the switch?
__________________
Stock 87 IROC 5.7L Factory Bose Stereo, T-tops
http://www.cardomain.com/ride/454339
2006 Pontiac Grand Prix GXP 5.3L 303HP
http://www.cardomain.com/ride/3885580
Tom87IROC is offline   Reply With Quote
Old 05-03-2011, 11:40 PM   #3
Registered User
 
Join Date: Jul 2001
Location: San Francisco, California United States
Posts: 769
Send a message via ICQ to stanghunter211 Send a message via AIM to stanghunter211 Send a message via Yahoo to stanghunter211
Re: Windshield Wiper Problem??

You can replace just the cover, which contains the circuit board. This is likely the issue, as the motor itself seems to work. Worth a shot, cheaper than buying a whole unit.
__________________
89 IROC-Z
ZZZ/AFR180's/XFI268
Best 1/4 mile run of 13.80 @98mph w/ 1.9 60ft (Untuned)
stanghunter211 is offline   Reply With Quote
Old 05-03-2011, 11:40 PM
 
Reply Post New Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield wiper problem 98camarov6power General 1967-2002 F-Body Tech 8 06-01-2010 03:22 PM
Windshield wiper problem lovemyblackz28 General 1967-2002 F-Body Tech 7 05-19-2010 08:30 PM
Windshield wiper Problem! Red93Camaro General 1967-2002 F-Body Tech 5 05-04-2008 04:42 PM
Windshield wiper Problem JCETA General 1967-2002 F-Body Tech 2 09-24-2007 02:36 PM
Windshield wiper problem??? Jeremy95LT1Form LT1 Based Engine Tech 0 07-11-2003 09:50 PM


All times are GMT -5. The time now is 10:51 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.