My brother is having problems with his TBI car? suggestions?? - CamaroZ28.Com Message Board


Reply
 
LinkBack Thread Tools Search this Thread
Old 01-25-2011, 08:35 PM   #1
Registered User
Thread Starter
 
Join Date: Jun 2001
Location: San Jose
Posts: 378
My brother is having problems with his TBI car? suggestions??

my brother has a 1990 TBI and someone sold and installed the wrong tranny into the car. They Put a 4L60e in it instead of a 700r4. It seems to run ok still but doesnt downshift and speedometer dont work and seems to run better when he manually shifts it. ANyways what problems can this cause?? Also, the car seems to be running poorly, a big lack of power and getting bad mileage. Could this be at all unrelated like possibly bad MAP sensor or TPS sensor?? Or is this all because of the 4L60e?
MauriSSio is offline   Reply With Quote
Old 01-25-2011, 09:51 PM   #2
Registered User
 
funina91ss's Avatar
 
Join Date: Apr 2001
Location: Huntington,WV
Posts: 1,331
Re: My brother is having problems with his TBI car? suggestions??

I guess he is lucky it even shifts at all. His only option is to run it the way it is or pull it out and put a 700R4 back in it.
funina91ss is offline   Reply With Quote
Old 01-26-2011, 09:50 AM   #3
Registered User
 
redneckgames's Avatar
 
Join Date: Oct 2007
Location: Lincolnton, NC
Posts: 327
Re: My brother is having problems with his TBI car? suggestions??

a 4l60e is a computer controlled transmission. You have to have the correct computer (or a stand alone unit) for the transmission to work properly. I wouldnt run it like it is. Fix it.
redneckgames is offline   Reply With Quote
Old 01-26-2011, 03:10 PM   #4
Registered User
Thread Starter
 
Join Date: Jun 2001
Location: San Jose
Posts: 378
Re: My brother is having problems with his TBI car? suggestions??

Quote:
Originally Posted by funina91ss View Post
I guess he is lucky it even shifts at all. His only option is to run it the way it is or pull it out and put a 700R4 back in it.
yeah, hes making plans on looking for somebody to trade trannys. But i was surprised that it even shifts as well. But you think thats why it feels like really down on power?? It starts from 1st gear and all but power FEELS as if its doing a third gear start (obviously its not because you can feel it shift or manually shift it). Would not being able to connect it to a pcm make the tc bog down the engine like that? or would the low power be engine related??
MauriSSio is offline   Reply With Quote
Old 01-27-2011, 12:09 AM   #5
Registered User
 
Join Date: May 2007
Location: Fort Atkinson, WI
Posts: 344
Re: My brother is having problems with his TBI car? suggestions??

As far as your bad gas mileage question my 89 formula with the 305 TBI gets 12-13 mpg in the city, and 25mpg on the highway. Most people I knew that had the TBI got worse gas mileage than people with TPI. Both of my TPI cars listed below get 16 mpg city and 23 mpg highway. My car is in excellent running condition with 129,000 miles.
cars3 is offline   Reply With Quote
Old 01-31-2011, 12:13 PM   #6
Registered User
 
kd5icr's Avatar
 
Join Date: Mar 2010
Location: Carrollton Texas. Just north of Dallas
Posts: 39
Re: My brother is having problems with his TBI car? suggestions??

I agree on the get a 700r4. He also needs to make sure that the VSS is hooked up and working. After all the 4L60e is nothing more than a computer controled 700r4 but it has to have a computer to make it work. A 700r4 built will be great for his car.
kd5icr is offline   Reply With Quote
Old 02-02-2011, 03:25 PM   #7
Registered User
 
Join Date: Dec 1999
Location: MD
Posts: 2,022
Re: My brother is having problems with his TBI car? suggestions??

Uh, if it's got a 4L60E that isn't connected... I've got news for you... 1st gear isn't happening. The trans is in limp mode, which means a forced 2nd gear.
Marc 85Z28 is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Brake pedal on Floor Red97LT1 Suspension, Chassis, and Brakes 9 12-17-2014 07:13 PM
Camaro Podcast #482 - Camaro Z/28 Continues to Impress ChrisFrez CamaroZ28.Com Podcast 0 11-30-2014 09:41 AM
clicking sound icm replaced USAirman93 General 1967-2002 F-Body Tech 4 11-24-2014 04:37 PM
Subs Won't Play Vokabulis Car Audio and Electronics 2 07-25-2002 06:46 AM
2002 Camaro SS W/ T-Tops... suggestions? Desolate_Flux Car Audio and Electronics 4 07-23-2002 09:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:01 PM.


Copyright © 1996-2013 CamaroZ28.Com. All rights reserved.